Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Class not leveling, I'm lvl 49, warlord lvl 19, everything in class is blocked out or zero, do I need to be lvl 20? (Not a bug)

Please check the known issues list before posting a bug.

Note: If you are uncomfortable reporting your bug publicly you can privately message @Cyrup or @Kafka with the completed bug template.

Platform, device version and operating system:

Screenshot or image:

What you were expecting to happen, and what actually happened:
This is simply what you were trying to do and what happened instead. Example:
‘I was trying to start an Arena battle, but Gems of War loaded Broken Spire quest instead!’

How often does this happen? When did it begin happening?
Was this a once-off bug or has it been a consistent issue? Does it only happen after doing a particular game mode?

Steps to make it happen again
Sometimes there are certain steps that can lead to a problem that may not be obvious!
Example: I lose once in the Arena.
I then exit to the world map.
I then tap on Broken Spire on the map and then tap Arena.
Broken Spire’s quest loads instead of the Arena

You need to make Warlord the active class, by changing to it. Customizing just lets you buy levels and traits without switching classes.

I have warlord selected, but the warlord cry is still 0/250,

JestfulChangeling12, right? Looking at your defense team, your hero currently doesn’t seem to have any class selected. Please post a screenshot of your hero portrait in the upper left corner of the world view, it should say “Warlord” below the head.

1 Like

Hi @Wolveted

I reopened your ticket on Zendesk, are you experiencing a lost account or a bug/technical issue?

Your right, I thought it was selected, cause it was only one open, but I tried selecting and it worked. Thank you very much, now I am 5/250. Yeaa.

Yes and other solved. My phone rebooted and I had to reinstall everything, I guess I had never linked the account, because when I linked i could only bring this new game I started and my xbox version. Can you retrieve my lost game? I dont remember the old guild. As for the warlord class someone pointed out that it was never selected, I thought it was, I did as they said and it works now. Thanks for getting back with me. I had a bunch of legendaries and about 10 mythics. Lost tham and all my gems. Frustrating.

I can help you recover your account, but I’ll follow up on the ticket.

Thank you @Fourdottwoone

Keep in mind to select talents for your class, they also start out unassigned once you unlock them.

1 Like