Bug Report - Lion and Tiger Issue (Not the PVP one)

I initially posted this in the existing thread about the traits-related bug in constructed, but I’m afraid it wasn’t visible enough, as this is an entirely separate issue (and I think it might be more concerning for this weapon).

What you were expecting to happen?

"Pull a troop to the first place.
Deal 12 damage and Stun them."

And what actually happened?

"Pull a troop to the first place.
PERIOD." :disappointed:

What are the steps to make it happen again?

I’m not too sure, as the weapon has worked correctly a few times, but it’s at least the second time that it does no damage at all (it didn’t “Stun” either, not that it matters in Arena, but it’s probably worth noting). It happened in the Arena, but also at least once in an Explore game I made to test it out.

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!

That Dwarf was in the 3rd slot from the top before I cast my spell on him. As you can see, he was not impressed (let alone stunned ^^)…

This time the target was in the last position. No damage, no Stun cosmetic effect, only the Dervish effect.

I’m switching back to Soul Blade and steering clear from this weapon as long as this bug is there. :-/

Could you please look into it? Thanks in advance.


Tried to reproduce the bug.
I was against :
-Empty Slot- (dead troop)
-Empty Slot- (dead troop)

After cast on the Revenant :
-Empty Slot-
-Empty Slot-

Revenant didn’t take the shot.
For the record, I had already used that ability at the beginning of the battle, with all troops alive, and nothing went wrong.
Still investigating…


Trying to help, but might it be important that your target didn’t have any teaits to stun? That might at the least cause the stun effect to not show visically. Also I could imagine the damage only works if the stun succeeded, does anyone know?

I had targets to stun.

I made it happen again, it seems that all it takes for it to bug is for the first ennemy troop slot to be empty.

Edit : will make a last attempt to check if it can bug in another case

Thanks for trying to help, guys. Much appreciated.

No, that can’t be it. There are no traits in Arena ever, and it doesn’t stop Stun from taking place, albeit purely as a visual effect. It happens all the time when I pick the Manticore, for instance, and I also saw it work with the Hag. The fact that troops don’t have traits doesn’t stop the shiny stars from showing up. ^^

Also, the Lion & Tiger spell worked correctly a number of times for me, even in Arena. My best guess at this time is that what triggers the bug must have to do with having some dead troops in the opposing line-up.

Yup, it’s 100% of the time happening when the first ennemy slot is empty and never happening if the slot is taken before launching the spell.

Well, that sux, considering the spell is designed to get someone to that spot and boxing him to death, leaving the spot empty !
@Sirrian, do your thing :wink:

1 Like

At first i was like did you transform his two troops into one? Then i realized that these two pictures are of two different games.

The same thing is happening to me and its quite frustrating. The same thing also occurs in PvP as well and I really want to be able to use it in pvp. The fact that there is no damage or stun defeats the purpose of the weapon entirely. Could we please get a response as to when this will be fixed?


We’re look into this. We are having trouble reproducing this internally but we think we know where the issue is.

Thanks for letting us know. That weapon is pretty cool and would be a nice Yellow/Blue option once fixed (thankfully we still have Soul Blade to fall back on in the meantime :slight_smile: ).

That is is great news, the wep is a great addition to my roster so looking forward to it. Any way you can up the soul count you get from the other Blue yellow weapon to make it more viable for use?


I just tried this weapon. I fired it three times and on each occasion it pulled the troop into the first slot (previously empty), but did no damage. I think it stunned the troop the first two times, but not in this example below.

Here, I fired the weapon against Druid:

It moved him, but didn’t damage or stun him.

I’ve made a video showing the Lion and Tiger weapon failing to damage and stun a troop pulled into an empty first slot. It does work when the first slot is already taken. Note that I have reproduced this on both iOS (iPad Pro) and PC (Windows 10).


Just wanted to report that this bug still exists. I used it today and when first slot is empty it is a Dervish only, no dmg, no stun.

@Nimhain Can you update us as to the status?

It really is a nice weapon and one that deserves to be used, but it truly is unusable in its current buggy form.

Thanks! :wink:

I’d still really like to use this weapon. Could one of the devs acknowledge that it’s broken and on the todo list? The bug is easy to replicate, as demonstrated in the video above. Thanks! :slight_smile:

So we haven’t been able to reproduce this issue internally, but we are aware that some players are still seeing it.

As we have mentioned for the Stunned IK issue, We want to look at how the game is handling the order of resolution of effects. It could be that this may also address problem with Lion and Tiger.

1 Like

Still happening! Haven’t played arena since level 100 something but went for the trophy count this week and that’s when I noticed this big! Have lost a call battles cuz the damage didn’t take

I’ve just encountered this bug whilst using Lion and Tiger in Guild Wars battles.

I tried it against three different enemies including Tesla and Sheggra. In all three cases the first slot was empty and it worked to drag an enemy to the first place and Stun it, but didn’t do the Damage.

I then tried it in an Explore battle when all slots were filled and it did the Damage and Stun correctly, but if the first slot was empty, again it Stunned, but didn’t Damage.

As an additional check, I killed the second-slot enemy, then tried Lion and Tiger and it worked properly to drag an enemy to the first slot, Stun and Damage it.

I’m using the Mobile version on Samsung Galaxy S5

I just tried it and for me, if the first slot is empty, it does damage but it doesn’t stun.

This bug still exists.

First three slots empty, fourth troop with < 20 life. The damage alone should have been enough to kill the troop, but instead it was pulled to the front, took no damage, and wasn’t stunned. @Nimhain, are you still having trouble reproducing this on the mobile platform?