7.2 Hotfix

Hey everyone,

Just wanted to make one new post here for an update on the fixes we are releasing so there is no need to run around to various threads to get an update on an issue.

Will also be updating the relevant Known Issues articles, if they haven’t already been updated.

Today we will be releasing a hotfix for the following issues:

Compensation is as follows:

  • Global compensation is TBC, expected to be sent out early next week
  • Purchases made before the Underspire reset will be compensated back to you once the fix is live
    • Along with an additional Lantern or Torch that was previously purchased
  • Underspire Guardian rewards that were not received will also be compensated once the fix is live

As for owned Troops appearing as unowned this requires a client fix, which we have tested but will need to pass through QA and submission. So the earliest will be start to mid next week. But again, once we have something confirmed or an update, we will post in here again.

These are the major issues we are currently trying to fix ASAP, this does not mean all other reports are not also being investigated.

For example, we intended to release a fix for the ‘!’ Mail icon with the missing Troops but this requires some more in-depth testing before we can release a fix for it.

Also, another example, your feedback requesting the return of Glory to the World Map and moving Souls to the inventory wallet has also been passed on & looking into possibly more customisation on what resources are displayed on the World Map.

Note for Switch players, due to these fixes going out there will be a slight delay in getting 7.2 out as we need to resubmit this version so it will include these.

Thank you for sharing your reports and feedback! We in CX appreciate your patience while we got responses out to your tickets and your understanding while we have passed these issues on to the team as soon as possible


WAIT! Actually it’s the other way around! Return Glory to World Map and you can put the Souls only in the wallet. Also, it’ll be good to have the Gold per Hour info back.


Thanks for spotting that, have corrected it.


I was hoping you would mention the bug that is concerning one of the top Guilds on Steam.
Namely our Guild leader who has too much gold on this account. You are well aware what Guild and who I’m reffering too.
And you aren’t willing to even acknowledge the problem or help him. Ignoring several support tickets.

At least one of our members’ accounts I’m aware of, you suspended, because he wrote something on this forum you didn’t like.
This is how you treat your customers? Free players or otherwise?

1 Like

Hello :slight_smile:

Just a quick heads up that the fix is rolling out now!

And as another quick note, the extra lanterns/torches will show when play underspire. (There’s no mail about it)

Please make sure to close Gems of War entirely before reopening it to receive the update!


Underspire reset AGAIN!


More bugs, my underspire got reset and I got my torches back. I then played one room and then the map wouldn’t advance lol. I am stuck at room 1 right now.

Reset again. And now i have 26 torches. I have no idea if that’s correct.

Try play one room and see if you map will extend after the win

Played one room. One less torch and i’m still at the beginning.

1 Like

This is so messed up!

I agree. Gold, Glory, and Gems are three currencies that interact directly with Chests (which are accessible from the World Map) but Souls are not.

Nice to hear that (hopefully) we’ll be skipping 7.2.0 & rolling straight into 7.2.x, and won’t have to report quite so many issues when the update hits our platform…

Hello again :slightly_smiling_face:

Please hold off on playing Underspire for now.

The development team are currently working on an urgent fix for this issue.

Man you guys are crazy with these underspire updates. Now im back at zero rooms just when I spent gems yesterday to catch up. Sure I have 36 torches and sure I’m a lightweight mellow player who you guys don’t care about but I used to spend. But stopped spending after the last screw up. Just curious do you guys do any QC at all? Do you outsource your programming (and if so, note it is not the job of an outsourced programing team to QC to this extent, that is an internal responsibility). I don’t chime in much but this time I just have to say you guys are crazy with these screw ups. And then you delete the threads hoping to sweep all your ignorance under the carpet. Ugh.


Yup, I just played the first room 3 times in a row and it reset after each battle. Somehow it says I have 2 lanterns even though I didn’t buy any this week, but the torches at 48 is in line with having played none and purchased 5 each day. However, they don’t do me much good at this point since progress doesn’t save.

I would gladly just take my 200 gems back, and you can keep the torches I purchased, and then I’ll just leave this mode alone for the week while you work things out.


maybe you should think about an IN-GAME way of delivering this message? maybe spare a single solitary thought for people who play the game instead of only the people who check this topic?

but hey, nothing 50 apology gems can’t fix RIGHT DEVS


Hello :slight_smile:

Apologies for the inconvenience.

The fix should be live once again.

Please make sure to exit Gems of War completely before reopening the game in order to receive this updated fix!

So the update reset underspire, and the fix for that reset it again.

Is this just going to happen every time any kind of update is released?

I do appreciate returning the lantern. Thanks for listening to that feedback.


I got more torches but my Underspire still reset. Is that normal?

Ok. Help. Since update, I can’t purchase anything(Xbox)! I get a gray screen and a line at the bottom, and the screen darkens, and it just all goes away. I tried different accounts. I tried deleting game and re downloading. I even bought a game on Xbox marketplace, so I’m not sure what it is. I was going to buy heroic booster, but don’t think this is going to get fixed in time. I haven’t heard anyone else with this problem though…