3.1.5 Known Issues (PC/Mobile AND Console!)

So…I’m confused. Are all the Troop problems not considered known issues?

None of the cards have their kingdom symbol on them (why would that be removed?)
None of the filters work on iOS except a name filter (why would you change something that was so intuitive?)
The kingdom levels on the kingdom screen don’t make sense anymore. I leveled up my new mythic, thinking I might figure out what they mean by “298/300” in Forest of Thorns and there was no change in my kingdom level. What? Why?

There were so many great things to this update, but all of these regarding troops and kingdoms are just…confusing. With none of this mentioned in the patch notes, nor up at the top here in known issues.

2 Likes

If you click the transparent arrows on either side of the fields, you’ll modify the filters. This was a UI blunder, but the filters do work. (See my post above)

This doesn’t sound right. Every person who has shown a screenshot of their points totals has had the correct values. The level numbers just went from cumulative (3498/3500) to star-by-star (298/300).

1 Like

Ohhhh, that’s really goofy with the filters. That just made it that much worse with trying to find the kingdom you want. I kept trying to hit the name over and over. Thanks for that! Still not intuitive, but at least it works now.

And I’m not sure what happened with my kingdom when I leveled the mythic. I’ll look more into it, but I was pretty sure the number didn’t change when I leveled it. Either way, I’m not certain why that needed to be changed at all. Now the numbers on the left are essentially meaningless to someone new to the game.

On iOS, the tribute icon (pulsing stack of coins) is no longer showing up when I unlock the game after an hour. I have to do some network operation (like open Mail and hit X) before the tribute icon appears.

It used to appear automatically an hour after the last collection.

Over the course of a week, that’s a lot of wasted time clicking into Mail for no good reason.

3 Likes

This is how it’s been on console since our last update, unfortunately.

For those interested in the PC Port To Unity Request to reconsider list can be found here 3.05 PC Unity changes need to be rethought.

1 Like

I made an acct to report this. I have to close and restart the app to get the push tribute coins to show up, or it will just never show.

Here’s how I have got it to work. Select Mail, exit, Select Guild Exit. That should trigger the coin blinking for trubute.

Graphical issue:

Pretty much all buttons or sprites that have a shrinking animation can get stuck in their “small” size. This includes the buttons on the world map screen (“PVP”, “Mini Games”, etc.), and just now the 6-gem loading circle.

1 Like

My list of bugs and miscellany (all for iOS):

Serious issues:

  • The combo breaker doesn’t work anymore. It’s straight-up broken. I’ve had enemies get lucky skulls and lucky 4-of-a-kind in PVP, where it makes no sense for that to happen. (If for some reason this was intentional, please ship the person responsible to Mozilla where screwing up things that were once good is apparently their company motto. Then fix it.)
  • When multiple 4-of-a-kind matches happen at once, traits trigger multiple times. This means Kraken’s third trait can do insta-kills after a major event changes most of the board to one color, so fully-traited Kraken teams are currently nigh invincible.
  • The inability to quickly pick an item in the troop filter menu–e.g., having to scroll through traits one at a time–is not good. We need a scrollable dropdown as an alternative to the arrows. Letting users hold down the arrows would be a nice compromise, and is worth doing anyway.
  • The right arrow in Disenchant no longer goes up by higher numbers when you’re at a higher rarity and need to sacrifice a lot of troops. The left arrow being able to maximize is a good change, but the right arrow has changed for the worse. Best solution: Let the arrows be held down.
  • Reduction in gems for guild tasks, while not a bug, is seriously wrong. Not cool at all, especially with gems being used for so much more now. The assumption that everyone’s going to complete battles 4x faster because of the new animation speed is bogus, and anyway at that high a speed I find it unplayable.
  • Map zoom is forgotten between sessions. Maybe this was the case before, but it’s a bigger deal now that the zoom is completely messed up (see below).
  • When zoomed in on the map, the map doesn’t move as far when swiping.
  • Only 40 characters for the guild announcement? Good gads. I’m calling this a bug. Was it perhaps meant to be 140? Still not a lot, but at least that would be some kind of reasonable.

Aesthetic (but still annoying): (as seen on iPad Air 1 and iPhone 6)

  • Cards are now much too small. The reduction in size is no good; the old size was exactly right. Cards are now harder to read.
  • The kingdom sigil is not included in the card image. (This was reported above.)
  • Text sizes are wildly uneven across the board. This is especially bad with traits (the text is ridiculously big, especially with the much smaller card), and with the troop list when viewing a team. Someone seriously needs to take a look at how the text sizes are on iOS devices, because they’re all out of whack.
  • The map is zoomed way out. There’s no way to zoom in past a certain point, making the world feel small.

Room for Improvement:

  • With the new daily dungeon minigame, a reminder icon of some kind on the menu would be helpful. An exclamation point above the minigame menu (and/or Drifting Sands) would help. Likewise if your guild is in a war and it’s an attack day, and you haven’t done your attacks yet, you should have a reminder to attack. And also, if there are seals waiting to be collected, an icon might be a good idea there (maybe not the exclamation point, unless there’s a substantial number of seals like 100+ to collect).
  • Chat should default to the last mode you used. If you were in guild chat, that’s where it should open up.
  • The chat icon should probably pulse softly when unread guild chat messages are waiting. This way, newbies who don’t think to check it will be alerted and guild communication can improve. Yes, our guild has some newbies.
  • I still don’t get why I’ve done all kinds of chests and have never had one mythic, but my wife is closing in on half a dozen after having opened way fewer chests. I know it’s luck of the draw and there’s not much to be done about that; I’m just venting with that one. (At least Path to Glory II will get me one in a few days.)
4 Likes

Even if it does then you should be able to email support with your email, hero level, invite code and as much information about your account as possible and they should be able to help you recover the account.

Very easy first turn win

1

or maybe not

2

This also caused another loss

Untitled

I’m losing enough on my own I don’t need the game to just give me random losses

In addition to @LummoxJR’s excellent list above, I have a few other graphical problems with the world map on iOS.

  • Not only does the map not remember your zoom level, it defaults to world center on restart. Defaulting to “centered on your home kingdom” like in the past is much more pleasant
  • Kingdoms at the edge of the map do not behave correctly. See the image below. Note that the Urskaya shield is displayed below the original on the map because the game won’t let itself scroll far enough north for the two to line up properly. There is also a sideways offset, but more on that later.
    IMG_1030
  • There is a persistent sideways waggle when selecting and dismissing the kingdom menu repeatedly. Even though the map is supposed to be centered on the kingdom before the shield menu pops up, the game thinks it’s slightly off-center.

  • And one more graphical oddity. Many of my Guild Wars opponents have their home kingdom backgrounds offset 50% in the GW opponent portrait. See the image below for an example. The right side of the portrait’s background is plain gray, and the left side is only the right side of the typical kingdom scene.
    IMG_1028
1 Like

I’ve had a few random crashes here and there (iPad Air 1), but today I just had one during Guild Wars. I have a loss on my record and lost points because it crashes during a battle. Not cool. I want credit for that battle.

Dwarves’ Fortitude still allows them to be devoured.

The arrows showed up this morning. I’m guessing I was having trouble downloading some of the necessary assets. Anyway, it works now. Yay!

Has anyone seen that when they log in after update on Android - it keeps asking to down load content again… and again… and again?

It seems to start downloading after the first installation upgrade which I did count six updates screens ,it seems to want to restart that process - and either aborts after the first one because the updating was done or what not.

I have noticed that I am still missing content of my troops but I figure like in the past they come when I use them or need to show them.

1 Like

Holy mother of God. When Sirrian mentioned changing how the game resolves blobs into matches, I figured it would be a small change.

I just took a 53-health Eternal Nobend Bros to 0 on a single cast of Hellcat, meaning my double Krakens fired off nine times at a minimum. The board was not completely red, and in fact I have seen boards more full result in fewer procs of Kraken’s third trait.

One thing I did notice was that the game hung for half a second before resolving all those matches. Was concerned that it had crashed before everything went crazy, Nobend style.

@Saltypatra, are you willing to email me an NDA and the rules for how the game resolves matches? I’d be curious to find out if I somehow triggered an edge case or if the hanging meant a multi-threading-related glitch occurred and my Krakens shouldn’t have tentacled quite so strongly.

3 Likes

I was facing a Humility-buffed Draakulis (stealing >100 health per troop on cast), I managed to web and entangle Draak. When all status effects wore off Draakulis was only stealing 34 health per troop per cast, but I didn’t catch what its magic reverted to, I was only surprised that I won

tl;dr - troop magic is maybe not reverting to pre-web levels after the effect wears off

Has anyone else encountered this with Web and magic boosts?