3.0.5 Known Issues (PC/Mobile)

Thanks guys, wasn’t aware of this.

I’d like to make a bug report with regard to Wulfgarok, his ability, and troops that summon on death. Specifically, there have been a number of times recently where Wulfgarok has executed his Fangs and Claws ability properly, killing an opponent, but NOT Consuming anyone, despite there not being any Impervious enemies who could be “blocking” the Consume. I believe that this is happening because the Fangs and Claws target has a Summon On Death ability, and the Summon is somehow interrupting Wulfgarok’s Consume.

I have lost at least four Guild Wars matches due to this recently. I’ve definitely seen this when the Targeted troop was Drake Rider (twice tonight, against the same enemy team!), but I think it’s happened with other Summon On Death troops as well.

EDIT: Actually, I can recall having eaten the very Troop that was summoned going up against a dragon deck, so I suspect that this is specifically a Drake Rider bug.


Team slot position get’s messed up when clicking a team, and then going back out.

To demonstrate how broken it is:
Go to the troops screen
Scroll all the way down in the team list.
Click on the top team, which should only be partially visible (so 4th team from the bottom).
Click the team again to go back.

The team you clicked is now suddenly the third one on the screen, instead of the first one.

I just lost a team due to this, because I was going to edit the next slot, which was the previous slot when I came back out of the team I looked at.

So yea… not happy

This says “appearing”, but that to me says they would show incorrectly in the scout part, but then be correct in the fight. Which, at least in my case, is not how it is, the stats from the scouting are what I get in the battle.

Also, I was under the impression that the PC stats were higher, but doing a quick test now, the PC stats, for me, are actually lower. By a lot in some cases. Eg. Kraken has 22 armor / 27 life on PC, but 30 armor / 35 life on mobile.

Statues are still not showing active or a bonus timer


Are you checking in ranked pvp or guild wars?

Guild wars only.

@3vangelica : yes, the war win or loss is considered when the day ends, but any fight past that threshold still add points (and those points count for the final war points, the one that says which reward and how much your guild moves up or down).

So, in your case, someone in your team made at least 2k points for day 3 war but most probably during 4th day.

Just encountered this:

The game was stuck at this. I could open chat and click on troops but thats all. Had to close down the game to be able to exit the fight.


Problem is known, and shall be fixed by now. See Fix to Empty Board Bug

So there seems to be a bug with the kingdom levels going all out of whack. Do we have an update as to when this issue might get resolved? had 16 kingdoms at lvl 10, one at 9, and the rest at 5 when I went to bed. wake up and nothing is lvl 10 and have quite a few lvl 1-4 and some 7s. yep, that is not right.

I’ve done some testing at my end. I think the “sort by amount” ordering is created when you start up the game, and it doesn’t update the ordering when you acquire new troops.

Now, curious minds want to know whether the “sort by rarity” is also affected the same way, if you ascend new troop during the same game session. Or generally, any of the sortable attributes that can change during a game session.

1 Like

I noticed these 3 bugs:

Necromancy trait is calculating incorrectly. Status: Is working as intended

You’re sure about that? Granted I may just understand whole system wrong, but it’s weird:

I am using +50% Souls armor and have Warlock with Necromancy trait in my team. Should be getting 200% of souls per battle. My team has 60 souls per game cap. Sometimes after game I get 90, sometimes 63 and sometimes random amount in between.

Example from one of my recent games:

Now I don’t know, but 63 doesn’t look right. Even if Warlock has to survive to give me 50% bonus - and he died in that game - my armor should still kick in and give me 90 souls, am I right?

And games I won? I still get about 100 souls instead of 120. This system is either bugged or works so strangely I will need someone to explain it to me.


Using Filter option “Amount” lists incorrect order. Many 6 or 5 troops appear lower than they should.

Tried few PvP battles, passed 600 tier and didn’t get my reward. I got my “ascension” pop-up making it into new rank but didn’t get the “reward” screen and can’t tell if I got at least the reward itself.

That’s it :slight_smile:

Be sure to read my message, just above yours, for an explanation of why the “sort by amount” is busted. If you restart the game, the sort will be correct again. :slight_smile:

Sorry… :smiley: I just read the first post, it was not mentioned there so I put it down… again. At least they don’t forget about it :smiley: You may be right though. I didn’t investigate the bug, only noticed incorrect filtering for 3 days straight.

Yep. Also in regard to the amount of souls from a battle, I’ve done extensive testing with that, and even back with the AIR version, most of the bonuses don’t apply if you lose the battle.


Sort by level is also affected by this.

I finally leveled all troops to max level yesterday, and some of my previous level 19 mythics still showed up in between the orange cards, even after they where level 20.

Which is funny… because when I sort on level, and level a card at the bottom to 20, the list repositions me on the troop I leveled, and I have to scroll all the way down again :slight_smile:

Leaving and re-entering troops doesn’t help… like you said, rebooting the game fixes it.

1 Like

Bug report: Traitable cards show up without the green + icon on them.
It looks like it’s always a whole row (in the following screenshots, 2 rows in succession).

Notice how the bottom row doesn’t have the + icons? Ok… maybe that’s the end of the list then?

Nope… it continues 2 rows down :slight_smile:

Clicking a card without the icon, and going to crafting will show the + icon on the traits tab, and traiting is available when you go to it.

Closing the troops screen and reopening it fixes the issue (upon resorting on traitable).

EDIT: Issue is on console as well. Actually had the top row without icons yesterday. Which also means that blue (ascend) icons are also affected by this.

This is just a bug report. I’m in no way implying that this has to be fixed immediately, or should have priority over other issues.

1 Like

Hadn’t received a reply to Infernus’ spell query on his launching forum posting:

His spell that targets two random troops can a lot of the time only hit one troop. An example:
Troop 1 - 10hp
Troop 2 - 20hp
Troop 3 and 4 is irrelevant.
Spell hits Troop 2 first, killing it and causing splash damage to kill Troop 1. Second random hit can target the void in which Troop 1 was sitting, causing no damage to the only two troops left in the ranks.

Is this working as intended or a bug to be corrected?

1 Like

Not a huge one, but the different packs under offers all show the mythic troop symbol for day 30 instead of the legendary one. Was super excited to get it till I read! :stuck_out_tongue:

PC on the left, mobile on the right.

1 Like