1.0.8 - Known Issues


#1

Just so everyone is aware, we’ve got a few issues that we’ll try to resolve in the background now that 1.0.8 is live. I’ll keep the list updated in this first message.

  1. We’ve disabled some of the new purchases in the shop while we resolve our issue with Apple (Status: fixed)

  2. The Troop Menu is running a bit slow… sorry… working on speeding that up right now! (Status: improved)

  3. If you scroll backwards in the weapon menu (and occasionally in the troop menu) images will disappear. This is super annoying for us, because we’re SURE it had been tested! We’re investigating this too to see what can be done.(Status: fixed released on Steam, awaiting approval on iOS and Android, ETA after the holidays, sorry, but we’re trying to push it through as fast as possible)

  4. VIP Points are calculating incorrectly. Because Apple no longer has our Starter Packs or the 25$ Gem pack active, players are not being credited correctly with VIP Points. This will resolve most likely tomorrow when they’re active again! (Status: fixed )

  5. Playing multiple REVENGE battle in a row causes a lock up (Status: fixed release on Steam, awaiting approval on iOS and Android, ETA after the holidays, sorry, but we’re trying to push it through as fast as possible)

  6. Missing Titles for Dragon & Undead Bonuses (Status:fixed)

  7. Fully trait-ed up troops being given to AI players too early in quests and challenges (Status:adjusted so it shouldn’t be as brutal now until you reach level 50)

  8. Teams not being saved (this occurs when you create a team in the troop menu, then go straight to INVADE and choose to search for ANOTHER player. (Status: Cannot be fixed in 1.0.8. Will be addressed in 1.0.9)

  9. Incorrect income/tribute on Power 2 (1 gold star) kingdoms. (Status: fixed)
    NOTE: Correct gold is given for tributes & income! However there is a display bug on the kingdom menu that shows incorrect income. This is fixed on Steam, awaiting approval on iOS and Android, ETA after the holidays, sorry, but we’re trying to push it through as fast as possible)

  10. Bundle packs not awarding multiple traitstones. (Status: Fixed)

  11. Keeper of Souls Necromancy trait giving extra souls. (Status: Fixed)

  12. Arena offering troops at end at incorrect Gem price (Status: Fixed)

  13. Extra Gold Keys were awarded on the day after the update to all players when they logged in and received a daily bonus… based on the previous Iron Keys they held (Status: Fixed)

  14. The first Team could not be used for defense (Status fixed)

  15. Connection errors making it look like keys were being used and lost (Status: fixed)

  16. Connection errors making it look like Daily Gems were not given for subscription purchases (Status: fixed)


Two bugs report
Real vampires don't show up
New feature on PC: crash
Missing kingdom power bonus
#2

I cannot purchase any gems in the store, every time I I wanna buy something, an error occurred.


#3

Troop bonus text bug:


#4

We were waiting on a change from Google. It seems to be now fixed. Can you try again please?

Let us know if it works.


#5

Would this thread be the right place to report other issues we find?

After finishing my first 1.08 Arena, I was asked for 58 Gems to keep the three duplicate troops at the end. I already had all three of them at level 15, so it should have been just 1 Gem as it was with level 10 troops before, right?

I didn’t take a screenshot as I wasn’t 100% sure I had the Ogre at level 15, but I’ve checked after reluctantly selecting “No, thanks”, and I do.

Also, I had started that Arena before the patch, and done my first couple of fights with level 10 troops, so maybe it’s just a temporary glitch. I’ll see if it’s the same with my next one.

Edit: I also noticed two other things in the rewards at the end of this Arena:

  • I received 400 Souls, with Celestial Armor on, instead of the 600 it used to be. Nerf or glitch?
  • I received 3 Glory Chests. Since it used to be 2 Iron Keys, shouldn’t the equivalent be 6 Glory Chests?

#6

I sincerely hope this is a glitch. farming for souls was already boring enough!


#7

You and me both. And I just noticed I made a mistake in my previous post. 600 Souls is what we normally get from an 8-win Arena run with the Dragon armor, but it’s 800 with the Celestial.

I received 400 for this one, which suggests the armor bonus just didn’t apply.

Edit; uh oh :-/

http://gemsofwar.com/1-0-8-arrives/
“Souls Rewards from the Arena have been rebalanced.”

Could this be it? Armor bonus no longer applies to it? Or has the bonus itself been halved?

Also, is it a deliberate update that troops are now Level 15 in the Arena? I see it mentioned nowhere in the blog post.


#8

Yes - we had to rebalance the economy, some of the stuff just wasn’t working out correctly, particularly with new multipliers being added, and the difficulty settings from 1.0.7 affecting Arena runs greatly. Part of that involved lowering the Souls given in Arena.

To give an idea… if a player can win one game in the Arena, he will (with over 95% certainty) go on to win 8 games and take the maximum prize. With all the new multiplers, that starts to devalue our currencies pretty sharply if we don’t address it, and Gems isn’t a game that makes bankrolls of money to start with… so my apologies, but we kinda had to drop some of those values.

We’ve increased the keys given by 1… I know these keys only give one troop each, but I think the average soul-value of 3 Glory Keys should be about the same as the average soul-value of the 2 Iron Keys given before


#9

Your bug fixes say that creating a new team no longer gets forgotten.

I created a new team, and two minutes later I went back into the menu, it was gone.


#10

We certainly got ONE of those bugs… the only thing I can think of is that there’s another one there.

So the troops were completely gone? It wasn’t just that it had selected the team you used last battle?


#11

Originally I had two teams.
I earned 15 rockworms when opening keys, so wanted to make a team.
I ascended and levelled my rockworms, and leveled my Deep Borer. I gave a trait to a Rockworm.

I placed:
Rockworm, Rockworm, and (rockworm into fourth), then Deep Borer into third spot.
I went to team bonuses, renamed it, and changed the banner.
I closed the troops menu (in an unknown fashion, because I wasn’t paying attention).

I went to fight a battle, chose a non-rockworm team, did battle.
Came back, the team just didn’t exist. The name reverted to “Team#3”, and the banner was reset, and no troops were listed.

I remade it. And made a few others. And now it seems to have remembered them properly.


#12

It might be worth noting this.
When I was making my team, I had my troop list filtered by nation.
All these troops are Khaziel? Then I had only Khaziel troops showing when I made my team


#13

I think this is persisting from 1.0.7 - making a team in the troops menu doesn’t stick once you go into battle. Making a team in the pre-battle area does.

Might be some differences but this seems like the same as it was 24 hours ago to me.


#14

Thanks for your reply. I fully understand your decision and it’s good to know that this is not an issue like the armor bonus not applying.

So the base soul reward for 8 wins is now 200. I can live with that. It’s true that the Arena was more efficient for farming souls than even the challenges, which was a little weird especially since 1.0.7 made challenges irrelevant for kingdom leveling. As for the keys, 3 Glory Keys per Arena is fair enough. Honestly, the Arena is just my favorite part of the game in and of itself, the rewards are just the cherry on top.

I’m surprised you seem to suggest many people are getting 8 wins in the Arena in higher difficulty settings. I find it extremely hard, and I’ve been sticking to Normal for the Arena since 1.0.7. I can manage Warlord II for most Quests and Challenges, and it’s hard but usually doable for Invades, but in the Arena, the AI just rolls over me above Normal.

Level 15 troops changes the flavor of the Arena a bit, but I suppose it makes sense since PVP battles will soon see level 20 troops, so the gap stays about the same.

How about the gem price for keeping the troops at the end of the run, though? Was that a bug or has the price increased immensely? I’m more concerned about this than the soul rewards, I must say.


#15

Investigating that shortly. I think it may have been an issue where the troops carried over from 1.0.7. But we will test and make sure. Those troops should have been the 1 Gem Offer.


#16

Hmm… just tried it and it worked for me. So something else is afoot here


#17

Drat. I hate being right sometimes but being wrong is so much worse. 'specially with bug hunts.


#18

I exchanged 1,000 glory to buy 50 glory keys, then instantly crashed without any error message. No clue if I actually got the reward for that 1,000 or not. It oddly happened AFTER already exchanging 1,000 glory for 50 glory keys a couple times without crashing.


#19

In general, if it used the glory, it’s given you the rewards… let me check though


#20

Okay - we found it.
It happens if you:

  1. Edit a team in the TROOPS menu
  2. Go into an INVADE
  3. SEARCH for a second player
  4. Progress to the Team Select Menu.

It was indeed a second bug that we didn’t find. Will be added to the list and fixed in 1.0.9. Sorry about that.