1.0.7 A Few Known Issues


Hi Everyone,

I just wanted to update you all about a few known issues in the 1.0.7 version of the game…

1. The Game says I need a new version, but I can’t find a new version on the iOS App Store
Sorry! It’s taking longer than expected to get out there today. Apple can be a bit slow some days. It’s been released though, we promise, and it should soon be visible (normally take 60-90 minutes, but has taken 150 minutes today!!!)
Fixed! It should be available everywhere now.

2. I can’t find the SHOP Button
Yes - we removed it to make more space! You can still visit the shop by tapping the resources in the top right

3. On Steam my Scroll-Wheel doesn’t work.
We’re fixing that! There was an unfortunate interaction with the new version of Adobe Air. As soon as we’re done with PAX this weekend, we’ll get onto it. You can use PAGEUP and PAGEDOWN to zoom in the interim.

4. My Masteries are displaying incorrectly in the new Hero Menu
Yes. It seems that your Water Mastery has been accidentally added to the Guild Bonus for ALL MASTERIES
We tested this honest… but it seems the heroes we tested with must have had low Water Mastery scores and we missed it! This won’t see a fix until 1.0.8… sorry… but it is only a display bug, everything is working correctly.

5. Some of my cities lost a level
Some people tried to log in during maintenance and accidentally triggered an update to their city data. We fixed most of them but might have missed a couple. If your cities lost a level, DO NOT BUY ANY MORE LEVELS, and contact our support… we’ll fix it for you by forcing another migration.

6. The enemy hero was invisible when he cast a spell in the Arena
We’re currently investigating. It shouldn’t affect the gameplay though

7. My Troops seemed to get bonus stats in the Arena Menu before a game
It’s a visual bug only… and happens after you open/close the troop card to view it sometimes. Stats are correct once you get into the game though. The troop mistakenly thinks it’s getting one of our new bonuses!

8. My Troops Menu is missing the hero & bonus buttons at the top when I create a team
Just fixed this one - you’ll see it now on a restart.
We had a bad asset on the server that needed to be updated

How to get massive troop bonuses in Arena?
1.0.7 Server Maintenance
Is this a bug? Or is this just me?

Take your time! And thank you for 1.0.7 update! :smile:


Other problems I’m noticing so far.

Lord of Spiders’ Bonus description reads “[BONUS_KINGDOM_DESCRIPTION_3029_2]”
Duke of Spider’ (Missing ‘s’?) Bonus description reads “[BONUS_KINGDOM_DESCRIPTION_3029_3]”
King of Spider’ (Missing ‘s’?) Bonus description reads “[BONUS_KINGDOM_DESCRIPTION_3029_4]”

Lord of Stars’ Bonus description reads “[BONUS_KINGDOM_DESCRIPTION_3028_2]”
Duke of Stars’ Bonus description reads “[BONUS_KINGDOM_DESCRIPTION_3028_3]”
King of Stars’ Bonus description reads “[BONUS_KINGDOM_DESCRIPTION_3028_4]”

Will post more as I come across them. Looks great otherwise so far!


I know it’s just a display issue, but in some cases it looks huge… :stuck_out_tongue_winking_eye:


I’m digging the massive increase to speed.


I’m so loving it, it’s fun! :grin:

Just about bugs though, my PvP trophies are not registering (although my husband’s are). I’m going to try and battle in the Arena to see if it’s the case for all trophies or just the PvP ones.

Plus, Warlord max is HARDCORE.


Just wanted to confirm that alas, Arena trophies don’t seem to be taken into account as well.
But doesn’t matter, I’m too busy having fun. :slight_smile:


It could be that the game isn’t updating your display in game. Try closing the game and restarting it to see if that causes the game to update your trophies.

If that doesn’t work let me know.


Yop, it seems to be working fine now, apparently there was a secondary update Steam needed to download. ^^


I started a battle in arena where the opposing team had all life bonuses. Green numbers and the hero had like 22 life. I hadn’t figured out how to find the difficulty setting, so it was still on Normal, so I don’t think it was that. The next team was normal.


I can’t invade any more. From the PvP screen, when I click invade, it insists on making me update my hero’s weapon. Then, I click the buttons it says to click - first the “edit troops” then “hero”. It brings me to my Team #1, which is apparently my Defender group, which does not contain my hero. There’s this floating glove that seems to suggest I’m to drag a weapon to the “Hero” button on the top left, which I’ve tried. I’ve tried several variations on this as well, such as different weapons, or attempting to change to a team that contains my hero, but it won’t let me. So, I can’t invade until I get past this apparent glitch. Please help!


Additionally, I cannot exit from the floating glove screen except to close the game down entirely. Nor can I play any other form of the game, nor can I switch teams in any other screen in order to bypass this training exercise. Basically, the game is now completely unplayable.


Try closing restarting the game. We’ve made some fixes on the server that should help.


OK, I tried to bypass the training requirement by switching out one of my cards for the hero’s weapon it wants me to use. That caused the training requirement to complete. Then, I re-edited my Team #1 (which, again, I’m assuming is my defense team if anyone invades me, but it’s not clear) to include my original lineup, which does NOT include my hero. I went back to PvP and the training exercise had reset! I don’t even want to use my Team #1 when I invade, only when I attack, and I can’t change my attack team without editing my Team #1, which apparently must contain my hero in order to complete the “training”, no matter if I’ve already completed the training elsewhere. This is pretty wacky and I can’t get around it!

OK, editing here because I’m not allowed more than three replies (!!!) ----

I’ve closed and restarted the game a half dozen times because that is the only way to end the floating glove behavior. I’ll try resetting my Team #1 to include my hero, completing the training, exiting the game, restarting, and try PvP again. More in a bit…

Back again! I know you’re looking at it on your end, so here’s my update: I went into Troops and swapped out one of the cards for my hero’s weapon, as instructed, then exited the game via the Quit button, as one is supposed to do. I re-entered the game, and tested it on a Challenge game, and it was fine. I exited the game, re-entered, then tried PvP again, but my Team #1 still didn’t have my hero in it, so I got stuck with the floating glove again. UPDATE: I saw you PMed me as I was typing this! Gonna go test it now…

Last update (I hope!) –
WORKED! You fixed it. My eternal thanks.

Now that I’ve had a chance to poke at the new update, I have to say you made a lot of very clever updates. I was and am excited to learn them all better!


Yeah I found the “drag some stuff over to your team” tutorial bit really annoying as well. Eventually I realised that it wanted me to drag to the team members, not to the buttons up top.

I didn’t have to actually do any “training”, just needed to mess with the team until the game stopped bugging me.


Can you pm you Invite Code and we’ll try fixing things on our side.


noticed in arena, it isnt just the preview that is messed up, i have bonus hp during the game as well.


Do you happen to have any kingdoms maxed? And if so, which ones?


i have zhul’kuri maxed. It is the only one and is the banner for team 1, its my home kingdom.


Sadly, on my IPad mini (7.1.2) everytime I try to open a troop list in the new team management the game crashes.

It’s not a space issue (1.8GB available).

Any suggestion? With that problem I can’t set any team, so I can’t play :cry: