Weird map glitch


#1

My brother has had problems with the game incorrectly naming troops, kingdoms, and resources. Also, upon entering the Troop Menu, a bugged message appears claiming he has no troops, despite the fact he does. Starting anything other than a treasure map will cause a CLIFFY message to appear.

Platform, device version and operating system.
Xbox 1

Screenshot or image (sorry they the screenshots are bad)




What you were expecting to happen, and what actually happened:
My brother was expecting to login to raid boss, and the faction event, but the game gave the glitchy results that are written above.

When did this start happening? Earlier today probably around 6pm
Was this a once-off bug or has it been a consistent issue? Constant, recurs even after reset.
Does it only happen after doing a particular game mode? It starts happening when the game is loading after login. Names are messed up during this time as well.

Steps to make it happen again.
The only step I can say for certain is logging in.


#2

Looks like this issue. In the meantime, Check out this article, it might help.


#3

Thanks, I’ll pass it on to my brother.


#4

Hey there, I hope that aritcle helped!

It would be great if you could let us know:

  1. What language settings is your Xbox on?
  2. Is this the same as the language set inside Gems of War?
  3. When the game first started to show the issue, did it download anything when opening?

#5

It helped. The first suggestion (deleting save data) didn’t work, but reinstalling the game did.:+1:
As for the questions:

  1. English
  2. Yes
  3. No