Update and googleplay

it started with my tablet Saturday PM. the game had been fine but i had been having issues with the tablet. then suddenly it said it was unable to download some content.
and that crashed the game and GooglePlay and Luancher.

so I deleted the game and reinstalled.
it worked for a few hours and then did the same thing.

so I went to Nox and tried to play it on the PC. it told me I had to update the game.
which i couldn’t do, so I had to delete it.
when i went to reinstall it, it was there on GooglePlay but it would not let me install it.
the button was broken.

two different systems, both seems to have issues with the new update and google play.

what i want to know is if it’s on my end or if the new update somehow isn’t on Play yet or is messing with it.

is this a bug to report or do I need to go to support?
asking to see if this is a widespread thing or not.

I’m on android as well and it works fine for me.

You could play it on steam on PC while it hopefully gets figured out what’s wrong.

I’d write a bug report for this, as detailed as possible.

Hey @danac

I’m very sorry to hear that your having such a hard time updating Gems of War. So this can be looked into can you please contact our Support Team who will be able to assist: https://gemsofwar.zendesk.com/hc/en-us/requests/new?ticket_form_id=360000013356

OminousGMan - Support Human :male_detective:

1 Like