Unable to finish Adventure Board task

On Steam and Android

What you were expecting to happen, and what actually happened:
After retreating from second battle (used wrong team) i am not able to neither finish these battles, nor even click on it.

How often does this happen? When did it begin happening?
Only once, right now.

Steps to make it happen again
I have no clue and i also don’t want to make this happen again for any GoW player

1 Like

Might be yet another aspect of the chat disconnect bug that is getting ignored for months now. If you close and launch your game again, are you able to play the battle?

I tried, i even tried to restart game on PC (bug happened on Android), bug is still there

Okay, are you able to select the first battle?

holy moly, yes.

Maybe the devs want to reward you with some extra deeds? The interesting part will be whether it unlocks the second battle or allows you to replay the first one as often as you want. :thinking:

That will be a secret forever :wink:
But thank you very much for this tip: it shows Deeds of Fire II, so i assume it is the second battle.

Yes, i was able to do the first fight again and then finish it, so only replay of first battle

1 Like