Treasure Hunter Finish a Treasure Hunt with 2 or more Vaults - buggy?


#1

Ok, as you can see from the name of the topic it seems like the Treasure Hunter trophy on Playstation 4 seems to be bugged.

In the description it says you need to finish the treasure hunt with 2 or more Vaults. I’ve done this several times (taken some screenshots, too) but I just can’t get the trophy. Is there anything else to do, then finishing the treasure hunt with 2 or more vaults?

The other two trophies haven’t been an problem. It just “Treasure Hunter- Trophy”.


Bug bronze trophy
#2

I am working on this trophy at the moment - one vault is the best I can do, so I cannot speak from my own experience.

But, on the playstationtrophies forums there are similar postings about the trophy not popping even with two or more vaults. One user even managed to get four vaults - but no trophy (link).

Then again, on psnprofiles, there are already some people that got the trophy (link).

So it seems to me that the trophy might be bugged / glitchy, at least in some way.

ceno


#3

My main problem is just: I am “wasting” treasure hunting maps for this on and on…I cannot count how many times since my last post I’ve managed the 2 vaults in a game and never anything happened.

There have been some rumours that it might also depend on the rewards (blue keys) you receive out of the vaults.

It is not difficult for me to get treasure maps during games but there are people who’s only chance is to buy them and it is a pain i.t.a. to know you won’t get anything.


#4

Same issue for me, but by luck I recorded the end of my game after getting my 2 vaults to found that at the end of the game, I got no trophy.

Here is the video https://www.youtube.com/watch?v=T0YNIpqNq8k

It is not public.


#5

This trophy is impossible, i can about 9/10 tries get a single vault and maybe one more red chest, most of the time i somehow fail to get a vault though having 3 red chests on the field… how the fuck you can get two vaults is beyond me… And yes i make loads of extra turns constantly but you dont always have 4s or extraturn options so your turns start slinking. The preq for this trophy should be changed into ‘get a single vault’ or ‘get the highest reward from treasure map hunt’ or something.


#6

It is possible to get 2 vaults the thing is you must get a feeling in which situation chest/coins change and which combination even of “only” 3 can cause a 4 lines. My strategy (and I saw that there are other players playing similar) to look as often as possible on the lowest row if you go for a 3 row (if there aren’t 4 or 5 ) by this you cause cascade and the chance to get falling rows that turn in 4 or 5 grows.

Sometimes it makes sens to make a 4 row instead of a 5 and the last thing is…well it is sometimes luck based.

But the problem is not doing the 2 vaults it is that the trophy doesn’t pop out. Now I am also recording it to prove I have done this several times.


#7

Again, I got 2 vaults and no trophy!


#8

First thing after update my gf tried out the treasure maps and got that trophy on first try. Nothing special happened, loot wasn’t special or anything.

I don’t know why it’s not working for majority of players, but I do have loads of bugs others don’t seem to have. So my game is somehow screwed.


#9

FYI, thousands of players have earned this trophy - it’s uncommon for folks to have trouble with it.

That said, we’re still stumped as to why some folks aren’t earning it properly.


#10

possible networking and confirming glitch in cache? just total guessing.


#11

Well, because of all the network calls in GoW, almost anything can be chalked up to “networking glitch” - but this doesn’t seem like that. Seems like a few people can’t get it - so there is probably some common attribute all of those folks have which is at the root of things.


#12

Ah last time I checked it was 0.1% of all ps4 players who had achieved it, so I assumed it was because of the bug.


#13

Bugged for me … :sweat:


#14

Unlocked the achievment 10 minutes ago. Dont know why it is bugged for some people…


#15

I think only bug in ps4 …


#16

I finally got it last saturday. Was the first time I got two vaults but it does not pop the moment you “create” the second vault but when you run out of turns and the loot gets collected.

I got 1 Gem Key and 1.000 Gold if I remember correctly. So nothing out of the ordinary.

But just a few hours later I already got the first messages from other players, wondering how I got that trophy because it didn’t pop for them.

ceno


#17

This is a good point - achievement will NOT happen when you get the vaults - but only when you “finish” the treasure game have have 2 vaults on the board. That is the moment that we access the server, and check things like acihevements.


#18

I managed to get 4 vaults in a run and sadly no trophy popped (PS4). I did it like two or three more times, but still no luck. I even captured the last moments of my 4+ run as a proof (here). Maybe this will convince you, that something just isn’t right with this trophy. I’m sort of a 100%-Hunter for trophies and this really bugs me .___.’


#19

We believe you! On a sidenote, though: Even if you did get the trophy in that video, it wouldn’t be visible as the PS4’s built-in video recording doesn’t include those things.

Everything that gets overlayed on the video by the system (like messages from friends, invites or trophy notifications) is not visible on the recorded video.

But that doesn’t change the fact that this particular trophies is somehow broken and I hope it gets fixed soon :confused:

ceno


#20

That’s true. On the other side I do have a profile with trophy logs etc. (psntrophyleaders e.g.) and I’m still missing that trophy.

I do not want to stress anyone. I just want the developers to realize that there is in fact some sort of bug and to do something against it. Not today, not tomorrow, but someday…