Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Tech issue] "Fatal error - Another instance is already running" showing in error

Platform, device version and operating system:

PC - Steam - Windows 10 Home Version 1903

Screenshot or image:

Screenshot_1

What you were expecting to happen, and what actually happened:

Shortcut links of the game are not launching the game. They are instead showing another instance is already running.

How often does this happen? When did it begin happening?

Happens every time unless launching directly from the Steam library. Started with the update.

Steps to make it happen again

Attempt to launch with a shortcut instead of directly from steam.

Additional info

Task Manager doesn’t help.
Restarting doesnt help.
Deleting the game and reinstalling doesnt help.
I have found several people experiencing the same problem on PC using Steam. All work with the same solution.

I believe I remember this error happening maybe a year ago as well but I dont remember why it stopped.

2 Likes

I am having the same problem. Thank you for posting this.

1 Like

I get the same fatal error on my hubby’s Surface tablet when launching from shortcut. I have to launch from Steam library.

Windows Pro 10

Yup me too on both my PCs since the 4.9 patch

My solution to this is to just trying to run the game. Eventually it works. Usually.

This tends to happen around updates usually running from steam, deleting the old short cut and creating a new one will solve it.

Can you try? (I know you already did the whole uninstall reinstall thing, but it’s for science!)

1 Like

It partially solved it.

I am able to launch from a desktop shortcut. (seen below)

But my pinned shortcut on my taskbar still returns the error (seen below)

Screenshot_12

I launch from there about 99% of the time.

Have you tried unpinning the task bar short cut and re-pinning it from the new shortcut?

For some reason the task bar buttons don’t get updated when the game is updated in steam.

2 Likes

I have. I tried before uninstalling, after uninstalling, and after creating a new desk top shortcut.

Tried a second time. Removed. Restarted computer. Started game from Steam directly. Repinned a new shortcut. Still has the same problem.

Edit - Checked with a couple of other people and their problem is the same.

1 Like

There is a workaround to get the game to launch through Steam library while still using a taskbar link, but it requires a few steps.

First, create a desktop shortcut (looks like you’ve already done this). This functions as a url that will open the game through the Steam app, which functions the same as launching the game from within Steam Library. Works, as noted. But you can’t pin this directly to the taskbar.

Next, pin the app to the taskbar like you normally would - locate the exe in the game folder, drag it directly to the task bar or right click/pin to taskbar while it is open. Looks like you have already done this part as well.

So now the crucial step… once it is pinned, right click the item in the task bar, select GemsOfWar, right click again, and select properties. You now need to edit the shortcut, so go to the Shortcut tab. Right now, it should be pointing directly at the exe in the game folder. Instead, we are going to redirect it to open the url sitting on the desktop. So in the box marked “Target”, put in the full path for the desktop shortcut.

That path should be:
“C:\Users\xx\Desktop\Gems of War.url”

Where xx is your user name, and C: is your primary drive.

Should look like this:

(Your steamlibrary is probably on C drive, thats fine, you don’t want to change the “Start in” field from what you had)

Optionally, you may now use Change Icon and navigate to the original Gems of War exe in the game folder to ensure that you get the correct icon on the taskbar while the game is closed.

I distinctly remember this was an issue some time in the past, though I don’t recall the “instance already running” being the error message, a while back, if you attempted to launch the exe directly either through the game folder or a normal pinned shortcut, it would fail in some way (see possibly: 3.0.5 Known Issues (PC/Mobile), hard fail for some apparently, for myself I just couldn’t get the steam overlay). To my knowledge, this was fixed somewhere along the line, possibly in PC/Mobile: 3.1 Patch Notes (line referring to “Server Status will no longer glitch” maybe?, can’t see any reports of this specific problem after this point until now). I’ve been using the redirected shortcut workaround since it was originally an issue and it has consistently worked for me. Main downside is the icon disappears sometimes and needs to be reset (usually after an update), but the link itself persists and should never have to be redone since it opens via Steam.

3 Likes