Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Tech Issue] Council of Chiefs on FireHD10 can't Fight

Device
FireHD10 7th generation

Can’t initiate fight on Council of Chiefs screen. The Overview, Rewards, Shop, Guild and Leaderboard all work but Fight does not.

This happens constantly. You cannot initiate the fight from the device. Works great on Samsung 10 and PC. But not FireHD tablet.

This has occurred since the Council of Chiefs started.

Steps to make it happen again
Open Council of Chiefs on FireHD 10 tablet
Try to click on Fight

1 Like

Hey,

Sorry I just saw this. Did you try fully exiting and re-opening the game?
Which part of “fight” wasn’t working? Could you open the fight tab at all?
Was the fight button greyed out?

Hi Kafka,

Thank you for responding.

I did try fully exiting and re-opening the game - no change

I tried uninstalling the game and reinstalling - no change

On the main page with the task bar showing starting with the “Overview” tab ,Overview, Rewards, Shop, Guild, Leaderboard - all worked except “fight”

“fight” tab looked normal just no response when selecting it.

I also ruled out that possibility of that part of my tablet’s screen being faulty.

Thanks so much for your help.