Stuck on title screen

I’ve never had any issues up until now but today I’ve been unable to get any further than the start-up screen, the loading bar fills up and then I’m repeatedly hit with the ‘can’t contact server. Please try again’ error. I thought the servers may be down but other players on my friends list are able to play.
Other games have been working fine so I know it’s not my internet connection.
I’ve tried uninstalling the game, deleting my saved data and rebooting the console all to no avail. Any help or suggestions would be appreciated!


I’m wondering if you ever had any success with this.
I hadn’t played the game for some time and had to do an update about a week ago.
It worked on the day of the update but ever since the loading bar goes as far as the letter n on the ‘Loading’ bar text, the background music starts but it goes no further and refuses to load.
I also uninstalled and reinstalled to no success.

Can’t think of a work around.


It also depends how long you are waiting. sometimes the connection with you and the server is slow and/or gets interrupted hence the disconnection. I have that happen a bit where I live so know why it happens at least on my end. In those situations patience wins out. If it simply is taking a while to load. I’ll go do the dishes or something. then come back a few minutes to check. Usually it won’t take on my end more than 5 minutes waiting at max loading bar. Now if it disconnects I close the program, then open it a few minutes later. So you could possibly wait a bit once you see the issue, to see if it clears up. When it happens to me its because slow or disrupted internet. Because even if you seem to have a good connection. That may be a good connection with you and your ISP to other locations. Though for some like the GoW servers there might be a bit more issues in conjunction with your ISP. Or it may even just be a local issue and you are getting dropped at times, as I said which happens to me.


Sadly, it is not the case.
I left it for over an hour and it hadn’t budged.

To try to resolve I uninstalled and reinstalled Same issue,
I then uninstalled. Removed my additional drive and installed onto the console drive directly.
Still same issue.
I created another account on the console and Bingo - works fine. That would confirm the game install is OK so I thought it must be corrupt user data. So I deleted the user data on the console back in my main account and restarted the console then the game. It did sync with the cloud save but stuck at the same point again.
At this point I gave in and considered that perhaps the cloud save was also corrupt so I deleted my save data using the ‘Delete Everywhere’ option.
Now, you would think that as the game data clearly works ok with the other account and I have deleted my save files that it would now work like the other account but still…no.
It’s a shame as I like to work towards the achievements and believe some additional content was added recently. I may have to create a support ticket at this point.

Thanks however for your input. Fingers crossed I’ll get there in the end.

1 Like

Awww sorry it wasn’t just a delayed issue. Was hoping it was so it wouldn’t affect your game too much.

1 Like