Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

Steam - PS4 Controller broken

I’m using a PS4 controller via USB. A couple of days ago, Steam had a software update. Since that update, controller no longer works. The game loads the controller configuration, however no buttons function.

image

One question:
Are you using same controller on other games and does it work with other games after the update?

If not, the problem is probably with that Steam update and you should report it to Steam.

Controllers in other games works just fine. Only GoW isn’t working. I only really play just a couple of games with controller, GoW is my main <3 game.

I also tested with another computer, same issue. Controller config loads, no response between game and controller.

I made an account just to reply to this! I’m having the same issue only with an xbox one controller. Works perfectly fine in every game but fails to be detected in gems of war (even though config loads). It is my main way of playing gems of war so it sucks. The only “fix” so far is to just keep plugging and unplugging until the inputs get detected.

Is there no one in our community that plays with a controller that can chime in? I can’t be the only one here playing GoW on PC who was affected.

Tried to get my PS4 Dual Shock work with GOW, ended up throwing it so hard in the wall that it all exploded, 50 bux in the trash bag. Sorry for not being much of help! :grimacing:

I play on pc/mobile but I use a controller. My buttons are no longer mapped for GoW as I have had them for the past four + years. and I’ve tried many different things but I cannot get them to function as they did before. Some buttons work, but some do not. Also, I have to unplug then replug it after each time of launching the game before steam recognizes that I am using a controller.

1 Like

I noticed my steam controller no longer works in GoW. I usually only use it for Vault weekends because it’s good for grinding with quick win teams that don’t often need to move the board. So the last time I know it was working was the last vault weekend last month. I noticed my XBox contoller would work, but only if I went in the Steam library, right clicked on GoW, selected Properties and set “Steam Input per-game settings” to Forced Off. So if you’re controller isn’t working you might want to try that setting. I’m guessing this was done to prevent people from using custom configs to automate input sequences.

It doesn’t help with my Steam Contoller though, it won’t work regardless.