Some sentences will crash in-game guild chat...?


#1

What you were expecting to happen, and what actually happened?
Entered a sentence, the game crashed. I tried several times (copied the sentence) and it never made it to the server since the game crashed.

What are the steps to make it happen again?
Try to post this exact sentence in guild chat : “Prideland’s color is red only, so you’ll find fire traistones only.”

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!
No.

What support are you playing on?
PC (Steam)

Any idea where this could come from?
My first guess was that the input string wasn’t escaped properly, but I’m not sure, since another sentence with 2 apostrophes somehow made it through (and apostrophes aside, I can’t see what could make your code crash in the sentence I used)


#2

I believe the ’ is making it crash. Try sending the message without it in either spot.


#3

That’s also what I expected to be the cause (am I wrong calling that an “apostrophe”?)
But, as I said, other messages with it made it through (even when there were 2 of them in the same sentence).
Anyway, I tried without " ’ " and without " , ", it didn’t work. I rephrased it completely, no problem.


#4

We’re aware some sentences are causing crashes in guild chat. We’re currently having a look into what could be happening.


"find" crashes in-game chat
#5

“find” currently crashes it, so try to avoid that word if possible. This will be fixed for the next update.


#6

Are you using anti-injection software?
It could explain why some word are “restricted”. If they are not handle, they could make the game crash.


#7

That is the correct word for it. comma goes on bottom, and apostrophe goes on top’
period goes at the end. and this was a short lesson in stuff.


#8

can verify its the word FIND not the apostrophe. :smiley:


#9

reminds me of a game when typing whore, it would be turned into companion. Good old rappelz.


#10

not just find but also finds… so probably a * find * crash (ignor the spaces couldnt just have the *.)


#11

OMG, are we set back 2 decades to have typed user-input based crash really?