[Resolved] Blank screen in pvp and other places

Please check the known issues list before posting a bug.

Note: If you are uncomfortable reporting your bug publicly you can privately message @Cyrup or @Kafka with the completed bug template.

Platform, device version and operating system:
PC, windows 10

Screenshot or image:


What you were expecting to happen, and what actually happened:

This bug has appeared before. When the first update happened and many people had this bug we were told it was our outdated drives for our graphics cards:


That is not the case for me then or now. Since this update I have a blank screen when I go into pvp or explore. I can grab the corner of the screen and push/pull the dimensions of the screen to get flashes of what should be there.

This is simply what you were trying to do and what happened instead. Example:
‘I was trying to start an Arena battle, but Gems of War loaded Broken Spire quest instead!’

How often does this happen? When did it begin happening?
Was this a once-off bug or has it been a consistent issue? Does it only happen after doing a particular game mode?

This is constant since the update.

Steps to make it happen again

Just enter the game and it happens.

Sometimes there are certain steps that can lead to a problem that may not be obvious!
Example: I lose once in the Arena.
I then exit to the world map.
I then tap on Broken Spire on the map and then tap Arena.
Broken Spire’s quest loads instead of the Arena

Thanks for letting us know about this.

Can you please try the troubleshooting steps #6 and 7 here:

Which graphics card do you have?

1 Like

NVidia GeForce GTX 965M All of my drivers are up to date. I have verified the cache files with steam, uninstalled the game and I am reinstalling now.

I tried changing the graphics outside of the game as it said in #6 and that didn’t change anything so I went in and adjusted the steam properties to the first suggested one: “-force-opengl” . It worked. When I opened the game it opened properly and all of the screens are now visable. I have opened and closed it several times now and even put the graphics back on high and opened and closed it several times. It is working properly now. Thank you. What did I tell steam to do when it opened the game?

Great! I’m glad that worked.

You basically told your Graphics card to render the graphics using a different method (openGL), rather than the method it was defaulting to (DirectX) to put it very simply.

I’ll mark this issue as resolved now, but if you keep having this issue please reply here so we know :slight_smile:

2 Likes

This issue is fixed in the next update version, 4.3

1 Like