Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Reported] Weapons remain locked on event colors even outside the World Event!

I can not replicate this on iOS. I (1) restarted the game, (2) went to the Depths interface, (3) checked the filter was present in the team editor, (4) exited the Depths interface, and (5) saw the filter was absent in the Troops menu.

Edit: I just tried again, and I am now seeing this on iOS. I don’t know what happened the first time.

Later edit: I can replicate it on Android. Open the world event, go to the team selection menu, boom, the purple weapon filter remains locked outside of the world event as well!

I cant replicate it on PC. Tried PvP and Explore.

I have the exact same issue on Android 10, device: Samsung Galaxy A40.

Steps (all done after starting the game after daily reset):

  • Go to event map, select your first battle.
  • Build a full team.
  • Save the team but don’t fight, just go back to main world screen.
  • Open the Troops menu, select the Weapons tab, the purple filter is still locked.

Edit: the issue also occurs again after restarting the game and following the same steps. It also affects any team selection menu you open subsequently (PVP, Explore, etc.)

After fighting your first fight does it end? I still cant recreate it.

it doesn’t have anything to do with any fight. You open the World Event interface - From the Depths.
Once you go back to the normal game interface, and open the troops menu, weapons are locked on Purple. So I can’t change/create any team that uses a non-purple weapon.

The purple weapon limitation should be in place ONLY inside the World Event interface, nowhere outside it. Yet, it stays in place.

Once again, this has nothing to do with pvp or explore battles. Nowhere did I mention something about battling.

It seems to happen every time I enter the Event team selection screen (when I guess the filter gets actually applied). If you don’t change the team, everything’s fine.

Hello. Same problem here… Android device.

**** Xbox too *****

I have it on iOS as well.
As soon as I go into edit team from the world event, the purple weapon restriction is locked.
Restarting the game resets it.

iPhone11 13.4.1

Same here. Restarting the game cleared it, but going back into the troop menu inside of the event locks it again, requiring another restart.

The same situation on PC/Steam.
Troop selection works fine, only the weapon color is locked.
Restarting the game fixes the issue until you enter World Event edit team menu again.

Yeah, happened with me too. I play on PC with Win 10. I just had to restart the game to unfreeze it.

This is happening again in this Event. (Android). Whenever I go to my weapons, they are locked with the troops colors yellow and brown.

I have this too (Android as well). I have to completely shut the app down and go back in again to reset my weapons. But, as soon as I go into the event, my main weapons screen jumps back to be locked to just yellow and brown weapons.

Funny how this bug report was totally ignored - and one month later, we’re in the same spot… @Kafka, @Saltypatra - any chance to have the team look at this (repeated) bug? I updated the description/title in the original post

With this bug present after we participate the event and cause the weapons locked, the only solution I came (for now) is to restart the game.
I did not noticed last time, but seems that already happened. Sure your devs are aware of this and hoping to fix it soon.
Thank you.

@alv-thanos restarting the game was fixing it last time around as well. But this does not solve the problem on the long run.
And it kind of defeats the purpose of the community trying to help make the game better, if the devs ignore the bug reports…

Hey, just a quick note to let you know this bug report wasn’t ignored, I reported it (as marked in the thread title). I’ve brought this back up with the team today to see if we can get it bumped up the to do list.

Very sorry about this.

In the mean time, restarting your game will reset the Troop filter. I know it’s really inconvenient, but I just want you to know there is something you can do to get around the issue in the meantime.

2 Likes