Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Reported] Save Filter not working for Troops/Weapons

Platform, device version and operating system:

PC Mobile

Screenshot or image:

What you were expecting to happen, and what actually happened:
I have it set for upgradable normally so I see when I purchase or collect troops and can upgrade them. It currently defaults to no filter every time.

How often does this happen? When did it begin happening?
Just noticed today. Can not get it to set.

Steps to make it happen again
Attempt to save a filter. Exit and go back in. Filter will be cleared.


There is an issue with Playstation. One of the tasks is not being completed.

How do we resolve the Warden Hero task. Is it a glitch? I have a full team, class, hero weapon, even pet and it still is not being completed. Is it a glitch?

If restarting isnt working there probably is not much we can do until the devs take a look at it. It has popped up for several people.

1 Like

Ok, I thought I did something wrong. Thanks

Good day,

Same problem (PC / Mobile version) .

Same here with the Filter,

It’s not a major problem but a fix would be nice :slight_smile:

And have a nice day everyone.

Weapon Type in Weapon Filter

Yeah, that is a known one.

Ok I’ll delete thanks

No problem. I actually re-reported it in the Beta as well. Seemed more important since we had to select weapon type for a task.

1 Like

Having the same issue with Troop, Pet, Weapon menus since reset on July 20th.

Same issue here

Almost three weeks since the filter is not working, is it really that hard to fix such a minor thing?
Or do we just add it to the list of bugs that will remain for ages ? :smiley:

1 Like

To add information here, the saved filter does apply in one specific set of circumstances: When accessing the troops menu via “Edit Teams” in any mode where you have access to your normal teams. So basically, clicking Edit Teams before an Explore or PvP battle will used your saved filter still, but from the map.

This bug seems to have been introduced at the same time the “locked weapons from a world event carried over into locking weapons for the main troops screen” was reported: [Reported] Weapons remain locked on event colors even outside the World Event!

It is likely that the workaround fix for that issue caused this one.

1 Like

This requires a client update, so it was very easy and fast to fix however, we can’t just deploy a fix to the game server, we need the update to go through the whole approval process for every game platform we support.

It will be fixed in the next update 5.1


It took you very long to give us this answer. Is it really that hard to communicate such thing earlier?
I’d like to say thx for the update but meanwhile it seems to save a certain selection but it also permanently saves a text I typed in the search field.

Restart did not help. Now every time I go into the troop menu I have to open the filter and delete that text.
That’s really not funny guys.

1 Like

I marked this bug as reported on the 20th of July. I don’t normally explain server vs client update issues or the submission process.

I can’t reproduce the issue you’re having with the filter on 5.1.
The text only saves if you click “save filter” not if you click “apply filter” without saving it.
Maybe clear your filter, save it, then enter the filter you want to save without any text in the search bar, maybe you accidentally saved text in there.

1 Like

I tried this several times, now after reading your post I thought ok give it another try and it worked even though I did the same before.
anyway it seems to be good for me now, thank you :slight_smile: