[Reported] (NS)Forced to update to 6.7.5 and unable to log in

Game is updated to 6.7.5, then becoming unable to start

Hey @renovatio

Update 6.7.5 hasn’t been released yet, this problem that you’ve received is due to a connection issue. please follow the steps in this article https://gemsofwar.zendesk.com/hc/en-us/articles/360000330855-Error-13-and-Error-16-An-asset-has-failed-to-download

If none of the steps work please submit a ticket with our Support Team here; https://gemsofwar.zendesk.com/hc/en-us/requests/new?ticket_form_id=360000013356

OminousGMan - Support Human :male_detective:

as you can see that the patch has been installed already, we cannot start the game by skipping the update. but then it will stuck during the loading proccess. I can’t see any notification of update on iOS.

Clearly someone someone paid by 505 Games screwed up and now it’s preventing your ability to play Gems of War for hours or maybe even days.
The bright side is if you submit a ticket above already positing a report here…

The generous devs may just grant you tier 1 worth of Gems. Please, hold back your adoration towards their generosity.

Hey @renovatio

I notified the development team and they confirmed that 6.7.5 update was released a day early on the Nintendo Switch.

I can see you have submitted a support ticket, I’ll let the team know and get that looked in to.

OminousGMan - Support Human :male_detective:

Since Gems of War on Switch runs isolated from all other servers, couldn’t you just update that server to 6.7.5 a day early as well? That should allow Switch players to continue playing, without any side effects on the other game worlds.

You can solve the issue as mentioned below:

System Settings of the Switch → Data Management → Clear Save Data → GoW and delete data

This will not delete your account!! All data will be loaded and recovered from the server. You will be able to play again without losing any progress.

1 Like

Same Problem on the Switch.
I tried what MAgic1410 said too. (but wrong)
And I also reinstalled the entire software and I also have internet. Still not working.
Is there anything else I can do right now or should I just wait?

Do only this.

Reinstalling the game wont work.

If it’s still not working send a ticket.


Apparently I deleted the wrong data before. Switch set to English and it worked.
Thank you!


All people using non english language in game had the code ERROR 16 last week. something went wrong with those parameters during the update’s download. I know there is a way to fix this but some people couldn’t find it and they are still not back in the game. we had the same issue in may 2021. we lost players at that time. Are you planning a new update with the fix soon? thanks