[Reported] Graphics for Court of Foxes and Orpheus Priestess don't load (iOS)

Platform, device version and operating system:

iOS (both iPad and iPhone)

What you were expecting to happen, and what actually happened:

Graphics don’t load for the new Oprpheus Priestess. Her image is the animated diagonal crosshatch, and her spell is a placeholder icon that matches the Peasant’s.

Also the main image for the new faction doesn’t load, so technically this started in Friday.

How often does this happen? When did it begin happening?

The problem first apepared Friday March 10 with the new faction. Now it’s spread to the new Orpheus Priestess.

Steps to make it happen again

Play on iOS?

Adding to this: I tried using the Download All Assets button in Settings | Graphics. The download got stuck with 0.13 MB left to go, so I hit Skip Download and it said the rest would download as needed. Now when I try again it says all assets have been downloaded, even though they haven’t.

Same here - No Image for Priestess of Orpheus on IOS. I also tried to “Download Assets” and it got stuck at very end. I had to hit “skip” to continue.

Hello :slight_smile:

I really appreciate you guys trying to troubleshoot this issue yourselves first and letting us know the results!

The development team have been notified about the missing graphics.



What you were expecting to happen, and what actually happened:
See new unit “Orpheus Priestess” after I purchased her - but her portrait and image of her power do not appear on my IOS device.

How often does this happen? When did it begin happening?
Since purchase on morning of 03/13/23

Steps to make it happen again
I look for the image in Troop Editor.

Hello :slight_smile:

Thank you for the screencapture.

Just wanted to give you a heads up that the development team are currently aware of this issue and I’ve merged the two threads together as they were about the same thing!

Just to add that the problem also exists on Android (for me, at least). When downloading all assets the progress bar freezes at the point shown in the attached image.

Hello :slight_smile:

Can you please check your available storage space (just in case it ran out) and try to download all the assets again?

This is happening with this week’s new troop too.


Hi @Bramble,

I’ve done as bid.

There was plenty of storage, but clicking on Download All Assets came back with a message stating that there was nothing else to fetch.

So I fully uninstalled and reinstalled.

Then did the Download All Assets again. This whirrs away until reaching 951.88mb/956.46mb, then the only movement is the background scenes and spinning icon.

So, I’m left with ‘Skip Download’ as my only way forward.

Once past that, I can’t re-download all assets and I’m back to this…

Even though I still get this on the Event News page:

Hello :slight_smile:

Gotcha, thank you for walking me through your process.

I’ll put these screencaptures into the report and make sure to pass them onto the development team.

Sorry that this issue is happening!!!

  • Also, anyone else who is having this issue, please reply with your platform!
    (Android, IOS, PC/Steam, PS4/PS5, Xbox, Switch)

I am still missing asset for Eldritch Disciple and the pet Spike. Platform is Android mobile

Same here. I cant see Spike(pet), the bane of mercy, the spider throne, Orpheus priestess, silken fang, dead parrot, knight errant, dragonite gnome. I tried uninstall and install, download all assets. But these don’t work.

Btw the spider throne, silken fang, dead parrot, knight errant, dragonite gnome, they were seen before. timing is unknown. I’m android user and I have enough free disk space.

Is this happening only to me? The image turns into a pitchfork.

1 Like

Also experiencing this. on iPad Air G4 and iPhone 11.

Hello :slight_smile:

Can I get a couple of details to pass on to the development team?

  • Invite code please? (Just in case)
  • What type of android device are you using?
  • What game version are you on?


  • Is it just the troops with the missing graphics that end up having pitchforks as their spell artwork?
  • Or is all of your spells graphic a pitchfork?

Hello :slight_smile:

Which troop art specifically are you experiencing to be missing? (There’s a lot of different ones mentioned in this thread)

Please also let me know if you have the strange pitchfork troop spell graphic issue!

My missing troop images are Orpheus Priestess and Bane of Mercy, both on the actual troop cards and on any other instance, such as the “news” page. Looking at the OP card, I see the pitchfork image, but with a different spell title and text than the one on the forum - mine says “Desert Rose”. For the Bane of Mercy, the spell is “No Mercy”, and seems correct.

Both anomalies occurred immediately upon purchasing them with Glory.

I scrolled through the full list of all my owned troops. Orpheus Priestess and The Bane of Mercy are blank there too. I scrolled through my unowned troops and found Dragonite Gnome blank, with the pitchfork spell image.

1 Like

Hello :slight_smile:

Thank you for checking!

Also, that’s very interesting that only the unowned troop Dragonite Gnome had the pitchfork spell image. At the moment the graphics issue is a bit more complicated than you would think it should be.

On that note, can I take this response as you were only missing the Dragonite Gnome Troop graphic from the list?

Current & Known

  • Orpheus Priestess
  • The Bane of Mercy

Sudden Missing Graphics (Previously Visible)

  • Dragonite Gnome
  • Knight Errant
  • Dead Parrot
  • Silken Fang
  • The Spider Throne

To clarify:

Orpheus Priestess; I own it, the image is missing, the pitchfork shows in spell, the spell is Desert Rose.
The Bane of Mercy; I own it, the image is missing, the spell No Mercy is present.
Dragonite Gnome; I don’t own it, the image is missing, the pitchfork shows, the spell is Hoard and Hurry.

Knight Errant; I own it, no discrepancy.
Dead Parrot; I own it, no discrepancy.
Silken Fang; I don’t own it, no discrepancy.
The Spider Throne; I don’t own it, no discrepancy.

Bob Stinson

1 Like


Invite code : HIDE_PQAM
Device : Galaxy S21ultra
Game Ver : 6.8.0r43736

Missing graphics
・the bane of mercy
・the spider throne
・Orpheus priestess
・silken fang
・dead parrot
・knight errant
・dragonite gnome

Among them, the spell graphic is changed to Pitchfork.
・Orpheus priestess
・spider throne
・silken fang
・dead parrot
・knight errant
・dragonite gnome

Other than the above, there is no problem.

1 Like