[Reported] Faction assault shop

Platform, device version and operating system:
steam

Screenshot or image:

What you were expecting to happen, and what actually happened:
Opened tuesday Faction Assault. Clicked on shop tab.
Nice shop.

This happens whenever you open up the Shop tab for an Event that’s just started while being logged in over reset. It returns to normal once you restart.

Not sure if there’s a Help Centre article for it or not, but there could well be. While it is kind of buggy, I don’t think it’s a high priority for the devs, and there’s a simple fix/workaround. ¯_(ツ)_/¯

4 Likes

have you tried restarting your device?

2 Likes

Still, considering this is an old feature in the game, which has no problems with downloading stuff on the fly all the time, and constantly pinging servers, it’s pretty sloppy that it can handle everything else in the event except this one thing.

And since this is a weekly thing (along with many other events in the game), it is pretty sloppy that they can’t seem to handle them properly.
But they can quite easily handle fleecing us for money all the time, and adding new ways of fleecing us for more money.

2 Likes

I’m on steam. I don’t “restart my device”, since that’s not needed. Restarting the game itself is enough. It’s still remarkably sloppy from their end.

1 Like

I wouldn’t call it sloppy, but more a consequence of how they’ve implemented certain parts of the game.

When you start the game, it grabs the data required for things to run client-side as much as possible, at the loading screen. It would only grab things that are active that day (ie. world event, campaign).

Clearly, when a reset is triggered, it doesn’t force a re-download for some reason. It probably should but I don’t know their code-base and several other bugs lead me to believe that is sloppy and needs an overhaul.

2 Likes

I think it’s true for many aspects of the game. I stayed logged in during the Sunday-Monday reset and saw this on the campaign menu. Restarting the game fixed it.

2 Likes

Yep, if I’ve left the game open overnight before the weekly reset, when I go into the game it shows me a new Guild Event starting, but if I click on the Event Medal it just says [Medal Info] (or something to that effect) until I exit the game entirely and restart it.

That’s enough on android phones and tablets as well.

And yeah it’s kind of dumb but there are more important issues.

1 Like

Hey thanks for letting us know about these incidents with the empty shop and also the [TASK_TITLE] thing.

The game does need to download the latest content in order for it to show up which a simple restart will solve, however, we did implement some changes to help prevent this from happening as frequently for most people so I’ll mention it to the team.

2 Likes

Was slightly more annoying on my tablet, having to close/kill the task to do that (was a learning experience for me the first time…)
Simply “closing” the game wasn’t enough, since the task was still sleeping in the background.

And that’s one of the reasons this annoyance triggers me, have played plenty of other games with daily events & whatnot, and none of them require the constant restarting that GoW does.

Appreciate the response.

Worst case, the game should have a way to restart itself to force re-initialize daily/weekly/event stuff, instead of forcing it on the user.

Unfortunately, I am aware that this might be a code design issue and could take a bit of re-doing to handle. But the longer things are left like that, the more of a problem it gets to fix (due to the tendency people have to add more & more spaghetti-code workarounds to dodge a bullet).

Oh, yeah, you have to force close the app - but at least not restart the whole device. :sweat_smile: