[Reported] Burning gem causes targeting softlock

I’ve also noticed when using Fire Spirit, the match resolution takes a lot of time. I don’t think they tried this sort of mass matching of burning gems.

So basically any special gem with long animation effect, makes sense as all of them based on the same thing.

Hey everyone!

I’ve tried to reproduce this issue on our side and I haven’t been able to trigger this soft locking issue that you’re reporting.

Are you able to provide a video of this issue so we’re able to get a better idea as to what is happening and causing this issue to occur?

OminousGMan - Support Human :male_detective:

Gonna make one soon


This issue has already been reported several times, it also happens for other special gems that visually home in on a troop. See also these bug reports:

1 Like

Thx @Fourdottwoone for gathering those reports.

In all videos it’s clearly visible that every player tried to cast the spell BEFORE the last instance off an status effect gem flying over the board has reached it’s destination.

Easiest solution would be imo:
Give us a cancel button if we dont wanna cast a spell and let the game “update/reload” the current game status by doing so.
This would also solve a longtime request of the community.

1 Like

Also my own report (with video and screenshots) - [Reported] Lycanthropy Gem caused softlock when spellcasting vs. single opponent

Some complications:
1 - You should match the special gem in a way that grants an Extra Turn so that you can spellcast while it is still homing.
2 - Special gems seem to home in on their target at randomized speeds, so the time window for the above (i.e. ability to reproduce) is unpredictable.

Per my hypothesis above, it seems like when you cast a manual-target spell, anything that triggers an update to a target’s status (like Ironhawk’s third trait vs. a Submerged target) somehow removes them from the internal list of eligible targets for that spell, which is a BIG problem when it happens (even when it does not happen often). In all these videos (but particularly the last one) you can clearly see that the affected troop is highlighted as a target UNTIL the special gem actually hits them.

Naturally, this problem did not occur until the implementation of special gems and Ironhawk’s release. And it wouldn’t be an issue at all if we could just cancel out of a spellcast in the first place.

1 Like

It was easily reproduceable for me in my 1st attempt with the same team. I tested it several times with always the same soft lock.
Just make sure to get an extra turn and match at least one burning gem with Fire Spirit and try to cast Wrath Naga immediately afterwards while the spell of Fire Spirit is still resolving.

For the “Cancel-solution” I see some problems which should be paid attention on before.
1st: Pressing the “Cast”-Button already triggers traits like 3rd trait from Ironhawk which would result in an infinite combo of cast and cancel with any empowered troop on turn 1.

2nd: Adding some kind of “prevent you from selecting your own troops before the board state has resolved completely” will cause plenty of time delay where all preselection has to wait until everything is done at the current board state.

There are plenty solutions but the main bug is adding an effect causing troop to refresh its card making it unclickable. This must be fixed, should not be a big problem.

Yes, good catch. Literally the ONLY trait that should trigger during the target-select prompt is Stealthy. All other “on cast” traits must wait until the ACTUAL spellcast (i.e: popup of troop art & spell name).

If you play on console with a controller, you cannot interact with the board (e.g. inspect troop cards) during the opponent’s turn or during combos/cascades. It’s probably still possible to generate the softlock via controller, but the time window is that much tighter because you can’t queue up the spell mid-combo.

There shouldn’t be a trigger at all. The stealthy troop should remain locked as long there is another troop without stealthy in my team and it should be unlocked as soon the troop is stunned or one of the last remaining troops with stealthy.

If the stealthy troop(s) is/are the only left and

Okay, didn’t know about that. On Switch it works due touchpad.
So the 2nd issue would probably only affect Steam and Switch users. Would be a pain on Switch since the loading time for each battle is almost twice the amount of Steam loading time from my experience.

The visual reminder of “you can’t select that target right now because of Stealthy” is still useful to have, so technically it requires an event trigger – just not the same trigger as every other “on spellcast” trait.

Mouse input is processed more or less the same as touchscreen input.

And why there is no general keyboard input (or PC controller? can someone confirm?) is an age-old question.

Hey everyone!

Thank you to @DracoL1ch, @CaptainAwesome and @Stratelier for all the information you have provided on this issue you’ve been experiencing and how to reproduce this bug.

I have been able to encounter this issue and have logged this bug with the development team. I have also passed along the possible solution of adding a “Cancel Spell” button to Gems.

Also, thank you @Fourdottwoone for linking those other threads that appear to be related to this issue, I’m going through the process of looking into them using the new information everyone has provided.

I really appreciate all the help. Thank you :slight_smile:

OminousGMan - Support Human :male_detective:

I expressed myself incorrectly to this point.
What I mean is, there should be a trigger, but one that is already turned “on” from the beginning of a battle as along there is a troop with “stealthy” involved. This ongoing trigger should be turned “off” as soon as no troop without “stealthy” exists anymore or all “stealthy” troops get stunned. Turn it “on” again, when a troop without “stealthy” is respawned and so on.

I’ll try to make a bit easier:

1 or more troops with “stealthy” + 1 or more troops without “stealthy” = Trigger is turned “on” and prohibids selection of “stealthy” troops.

All troops or no troop have “stealthy” = Trigger is turned “off” and all troops are selectable

This should flip the conditions around and would allow us in rare cases to select a “stealthy” troop but it would prevent soft locks imo.

Just got this bug again, its not fixed in the latest patch

Which Device?
Which kind of gem is still buggy?

For me it’s fixed at least on Steam. So would be good to get some more details here…

All the same way as in my videos, steam. Will do a new one later

OK they went the hard way. Now if you have selected a troop card all special gem animations gets boosted so it’s impossible to reproduce the way I recorded it.

But in case if you DONT hold a troop card, animation use default (slow) speed. THEN you can select a the card and cause softlock. They didn’t fix the bug, they made its less likely to appear, yet I managed to get stuck at it yesterday.

Overall I understand the rush to release the content instead of a patch, so this workaround kinda plausible, but the team needs to remember these bugs still there, technical debt increases.

Aha. Which is still an improvement, but yes they must address the root cause.