Problem with rewards in invasion


#1

On PC

In invasion, the rewards of stage 6, and after stage 7, are checked as collect but i have nothing !
the nomber of towers is right, i have the level …

I looked in inventory ; the rewards haven’t been delivered.


#2

yes same here… i dont have claim rewards for 9 an 10 i think… some of my guild say too!!! what to do?? we spend so many gems and now no rewards!!


#3

The same here, my rewards of stage 8 and stage 7, are checked as collect but i don’t colected!


#4

If your guild completed that Stage within 24 hours after reset. Then you won’t be able to get that Stage reward for the rest of the week. Regardless of whether or not you yourself collected the reward from it.


#5

This is an unacceptable answer, seriously. So, a Guild pulls together to slog through the painfully repetitive Invasion to hit a reward level and it is just denied – no fault of their own, just the fault of the devs and their bug? The only recourse is to hit the next higher reward level? What a poor answer. And, on top of that, who wants to try for the next level just to have you change your mind again?

I am in software development and sometimes you need to just suck it up and deal with your bug. You should reset the levels back to what they were at the beginning of this Invasion and just deal with whatever imagined loss you are trying to recoup. Do your post mortem, and fix it for the next round.


#6

I agree. They should’ve waited to fix it for next time. Their fix is causing more bug issues than the original bug. But you’ll find over time… Anything that is in favor of the player. Gets fixed super fast.
Invasions were way more fun when completed in a day.
Either leave it be… Or let to guild stay at the current stage they were at. One of my guilds was halfway through 12… Got reset to 9. So that’s 3 stages of people completing them that may have no earthly idea of why they aren’t getting the rewards for them.


#7

I agree! We have a few members that missed collecting the rewards on Monday. We were half done with the last Portal when I left this AM. I’m sure Guild chat will be filled with angry messages when I get back.

The thing is: something internal changed a bit over a year ago at I2P in the way they handle bugs/issues/communication/etc and not for the better. Before this issue would have been handled properly to garner more good will and support for them, now…?


#8

This is unacceptable, I had to spend a lot of time destroying towers, I will not receive the rewards and stay for that?


#9

You’ll receive any rewards that your guild hasn’t received already. So if they did 11 stages on Monday. You’ll only be eligible for the stage 12 reward.


#10

It does not make any sense. The rewards appear as collected before I collect shortly after they have been achieved. How are you getting something the guild is missing?


#11

Maybe it’ll help if I show you example.
My guild completed all 12 Stages on Monday. Here is a present SS.
If we completed stage 10 now. We’d get none of the rewards.


My other guild, gems n roses, completed 11 stages on Monday. They are currently on stage 10 now. So they’d need to complete 10 and 11 without rewards. But will be able to get the rewards for stage 12 if completed by weekly reset.


#12

It still does not make sense, I was getting the rewards normally until stage 7, from 8 onwards began this problem. This is an error and should be corrected.


#13

I have the same issue on stage 8 and several in my guild report the same issue. It is not fair to the players to work hard to complete these events and not get the payoff makes people not wanting to play


#14

Same issue, worked hard and invested gems to support my guild to complete at least to stage 8, nearly got there but ran out of sigils, only to log in today and find the reward was supposedly collected, well it wasn’t. Bug or re- set or whatever, totally unacceptable. We work together to get the best level rewards we can and then they disappear or are removed. I ask the question in all fairness-what sort of game can operate like this and keep players? Fix and acknowledge your mess please, so we can move forward with confidence the stated rewards will be there to collect. A reward as set and seen by the player should be the reward they collect.


#15

I’m wondering if this is some separate bug that got triggered by the fix. My guild was at stage 9 before the fix. I collected no rewards. We are now at stage 10, I still haven’t collected. All my rewards show as ready to collect, including stages that were already passed on Monday:

Or would it not be apparent that I don’t get rewards 1-8 until after I press the collect button?

Either way, it is a fair bet that this, if it is happening as explained here, is unintentional, and the devs might not even be aware that it is happening. When I first read the complaints here, my initial reaction was “well, obviously they already claimed the rewards for that stage previously, got the kill limits put back before when that stage was completed and had to complete it a second time, and therefore wouldn’t be able to claim the rewards again”. But that doesn’t seem to be what is happening here. I hope someone comes along with a better description of what is happening or a way to reproduce it so everyone can get squared away.

So far, the common thread seems to be that people got put to an earlier reward stage and they pressed collect before they unlocked that reward stage again.


#16

Because you didn’t collect the rewards, you are still eligible to get them. Yes. For everyone that has gotten the rewards. The button is grey. Even after finishing a stage.


#17

But your previous post specifies “Regardless of whether or not you yourself collected the reward from it.” So is this just a misunderstanding of how rewards work (people claiming rewards can’t claim the same reward again in the same week, even if they have to complete the stage again because the requirements changed) or an actual bug with rewards (people can’t claim rewards they haven’t claimed this week just because of something that happened because of the required kill count change)?


#18

This confusion could have all been avoided if the damn event wasn’t borked in the first place


#19

I also haven’t claimed any of the rewards yet & they appear to still be claimable. Guess I’ll find out when we finish the last tier. Others in my guild have claimed rewards before the fix and aren’t having any problems. If they claimed the tier before they can’t claim it again. If they didn’t claim it they were able to when we hit the appropriate tier again.


#20

It’s based on reports of other players besides myself. Why don’t you hit the red button and find out? There’s a bug that causes people who didn’t get the rewards to still not get them now. Whether that bug effects you or not. Can easily be found out my you claiming your rewards. Either way… The bug would still exist though.