PlayStation 4 Store issues

Hey everyone! So just to update on the store issues that players have been experiencing on PS4. We’re still working our way through the issue with Sony, but would really appreciate if we could get some more input from the community to help us work out what is happening.

From our side of things, we can load into the game on US and EU versions of the game and see the store without issues. If entering straight from the world map it may take some time to finish initialising (about 20-30ish seconds), but the store always comes up. We can then purchase items and receive them correctly when returning to the game. If we close the game after completing the purchase in the PSN store, but before we return to the game itself, upon restarting the game we receive our purchase about a minute-ish after getting to the world map.

This is obviously not the case for a number of people here, as we’ve received many reports from people about this. We used to be able to reproduce the issues people were having in the store in the past and fix them, but we can’t seem to reproduce the issue in house. So while we’re slowly working with Sony (who still seem to mostly be on holidays, so it’s slow going), we’d like to take the opportunity for people to describe what’s happening to them in the hope we’ll be able to track this down.

Basically, what we’d like to know is:

  1. What is the issue you are experiencing? Could you describe what is happening, and what do you expect to happen? Videos can also help of what is happening.
  2. If you purchased something, what was it?
  3. Do you receive any error messages? Please post a screenshot if so, or describe where and what the error says.
  4. What region is your PSN account set to? If you’re unsure, and don’t mind giving your country, that will work as well.
  5. Did you download the game from a different account to the one you are using? If so, are the regions of these accounts different? We’ve found that you cannot access the US game’s store with an EU region account and vice versa.
  6. Any other information you think will be useful.

Sorry this has taken us so long everyone, hopefully with this we will be able to fix it up.


I’m assuming this is just about the main store and not the guild store, correct? I only ask because that things been blank for a lot of us since day one.

1 Like

Are you in the American Region on your PlayStation Network account (or live in a country which connects to the North American store)?

If that is the case, we are still waiting for Sony America to release the new in-app purchases in that region. This has been taking longer than expected due to the holiday period. Hopefully these issues are not related, but if there is a link between not receiving purchased rewards and the guild store not displaying items, please let us know.

1 Like

Yeah, I’m in the American region. The guild store has always been down, and the normal store was down for 2-3 months before it got fixed recently. I haven’t tried to purchase anything since it came back up.

1 Like

Hi, just created an account to respond to this post. PS4 user here and have experienced issues for a while.

  1. The issue: attempt to buy something on the actual store. I select the item: weekly weapon. It takes me to the PS store where I can pay for it. Once there I choose to pay for it, funds added to the wallet and then nothing happens. I do not receive my items or get a notification in game of my purchase but my account is billed. VIP level does not increase. Sorry no video of event.
  2. I have purchased weekly gems pack X2 thinking the first time did not go through and then a week later weapon pack to test.
  3. No error message received or any notification for that matter. Only way that I found out it was not a mistake was for PSN billing my card for payment on all purchases.
  4. USA
  5. I have always used the game only on this account and no other.
  6. It would be helpful if we at least got some notification of the error, or any action that is taken to resolve the issue. Did submit trouble tickets but have not heard back from them.
1 Like

I have been having the same exact problem. I’m in New York. And I have bought a number of things through the actual shop which it brings me to the PlayStation store. I purchase and load back into game and then there is nothing. It’s like nothing happened. But my card got charged. I have been working on tickets but it’s become a hassle trying to get anything done. I just had to factory reset my phone so now I’m having problem loading into 505 games to check status of my last ticket. And it take forever to get the right amount of things that I purchased and the get the VIP points.

I’m on the PS4
American Region

The last big update appears to have fixed the PSN shop for me, (though truth be told, I haven’t actually purchased anything since it got fixed yet).

However the guild shop doesn’t even show up for me or what appears to be 29 of my 30 guild mates. We can’t even access it to buy seals with the exception of Mitch, we love Mitch.

I HAVE submitted tickets and screenshots to support for resolution on the guild shop issue.

1 Like

Same issue here as most others are experiencing. I’m in the American region, on PS4. I make a purchase from the shop, my card is charged and I get a purchase completed successfully message, but when I go back to the game, nothing. I’ve tried waiting a few minutes to see if it shows up, and restarting the game and my system completely, but the purchased items never show up. This has happened to me three times in a row now, once with the Treasure Map subscription, once with the Keys Starter Pack, and once with the Lower Traitstone Bundle. All three times I contacted support and they rectified it very quickly (and then some!) so I am grateful for the fantastic support team at 505. It’s just terribly frustrating to have to submit a ticket every time I want to purchase something from the shop.

Thanks for the reports everyone, starting to see a theme here in that it’s American accounts. Don’t suppose anyone from the EU regions can confirm if they’re having the same issues or not? @Dustin1280; do you know if the beloved Mitch is an EU player?

The base game itself is the same across regions, however they each access their specific region store, which is about the only difference.

This is all very helpful though everyone, please keep it coming! Also, when submitting a ticket, it’s much easier for me to look at tickets review support requests submitted to our local team at Zendesk, as our support team is right behind me. XD

1 Like

Hi Alpheon,

I am on PS4 in Canada. My wife and I have separate accounts on the same console and we have never had any issues accessing in-game purchases for as long as we’ve played. We have mostly purchased daily gems and they always appear as soon as the store returns us to the game.

Neither one of us has access to the guild store, which seems to be the common theme, but the regular purchases are not an issue for us.


1 Like

OK as you know I’ve experienced everything that the posts above have. Lol I aint American.
I live in Australia and play on a PAL region 4 sony

I am almost positive he is EU region many of our guild members are German so that wouldn’t surprise me at all.

The store was always available to be, until I purchased the Deathknight bundle one week ago. I didn’t get the bundle, although my account was billed and I got a purchase completed successfully message (already sent ticket and receipt to support). If I remember correctly my husband downloaded the game, his account is US region, and I purchased the bundle in my account, set to south america region. Now the store won’t open anymore and I get the “failed to receive real money purchasables” error . The guild store has always been down.

1 Like

Hi there. US version. Ps4. When I log in it tells me I’m not in a guild. That is not the case as I am guildmaster for indica. Started That guild awhile ago. That is one issue. When I finally reload after 4 times, so my guild is loaded with my file, it has formatting issues on the roster page. After about 5 names down the option to promote/demote is off screen. There is also no way to invite a player through the player code.

The “not in a guild” error is due to server issues currently occurring. I’m not sure about the formatting ones though, sorry.

I’ve been having the same issues for a long, long time. It seems completely random as to when the store doesn’t work, and then when it decides to snap back to life. I recently purchased the Deathknight Bundle and some green traitstones. As with Renacht, I was billed, and everything seemed fine, except nothing actually happened in-game. Support was fast and great at resolving the issues within about a day or two. Now it’s been three weeks since then, and I haven’t been able to buy anything with real currency in the store. I enjoy the bundles most of all, and being a single bundle-worth of VIP points away from the next tier (the one where new cards start at level 15, so it’s a good one) is rather frustrating. Like many others, I receive one of two errors, either the store is currently unavailable, or that it wasn’t found. I’ve only played on the PS4, with this sole account, from one location (my home).

Would deleting the game and reinstalling have any negative effect? That’s about the only thing left I can think of trying on my end.

I bought spooky imp from the store with glory. And upgraded him to Mythic. When I use his special the game crashes. I are updated. Have turned on and off out play station. And such. Please help! He is my fav and I worked hard to make him mythic :slight_smile:

Thanks for everyone’s reports. I believe we’ve managed to find at least the store not loading anymore issue, and should have a fix coming in the next update to allow the store to load once again. We are continuing to investigate the error which causes the purchases to not be recognised. But we’ll have a more stable store overall in the next update.