Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Not a bug] Hoard Quality Upgrade 100% Chance - Still fail

Ok, so this to me is the dumbest thing ever.

Why do they even bother to visually display the upgrade chances if it’s all a scam. It happened to me like 3-4 times already.

It also fails a hell of a lot at 90%, but at least you think to yourself that you are unlucky, there’s still a 10% chance to fail.

But at 100% chance, fail… this is just stupid, devs need to learn some math.

What treasures did you add that failed? What was your Hoard quality? This does sound odd.

@Lyya, check back on this in an hour to see if the OP cleaned up their language.

Edited for content. OP, please watch your language.

2 Likes

I can’t remember what I used every time this happened, but, last time I used 2 King’s Crowns (25%), 2 Priest’s Chalice (20%) and 1 Gold Ring (10%).

Hoard Quality was 8/10 for this last try (and remained the same obviously). It was a bit lower for the other failed attempts.

PS: Sorry for the language, I was pissed.

In my experience, you get better results using 5 of the same item.

When you add treasures that equals 100% the hoard quality number displayed increases by 1. Then when you select to actually spend the treasures the number stays the same of course. When you add treasures that don’t equal 100% it works differently, the number only increases when you actually spend them if successful. Maybe this is what happened.

5 Likes

It’s just a weird way in which the upgrades are displayed like Fleg explained. I also found it strange the very first time but then since my calculations ended just like expected i understood it and payed more attention the next time i invested into another hoard up to level 10 to confirm.

All my three hoards are at quality level 10 by now and none 100% chance upgrade failed.

4 Likes

No, sorry but this is not what happened… like I said, I was also confused first and second time it happened, but by the 4-th time, I was paying attention, believe me.

100% Chance of upgrading… still fail.

I’m just surprised no one else came forward with this issue, maybe it’s a rare bug or something.

It sounds like you need a dev to check logs and see what might have happened. Given that it’s Sunday evening for them right now, this probably means waiting another day or two. I hope they can clear this up, because it’s obviously frustrating having an apparently 100% chance fail.

Try submitting a support ticket, which will hopefully get to them and not 505 Games; you don’t need help from the publisher for this.

3 Likes

Hello. Same just happened to me. Played on Android mobile, maybe that’s relevant.
My procedure (with observations):

  1. played some - dungeon, adventure from the board, random stuff
  2. unlocked the new faction - Werewoods
  3. completed Werewoods quest
  4. completed my first ever delve run in City of Thieves - once just for lulz
  5. approached hoard quality upgrade in Silver Necropolis
  6. fiddled for a while with different treasure combinations to see what works best for me
  7. quality meter was initially displayed as 6/10
  8. sacrificed a Sacred Treasure (+50%) and two King's Crown (+25% x2)
  9. quality upgrade chance displayed was 100%
  10. quality meter stayed at 6/10 after adding the above mentioned treasures to the bucket and it didn’t turn green
  11. after Add Treasure ~40k gold was devoured, faction level went up to 71 but quality meter stayed at 6/10
  12. I realized I am being robbed, but the robbery was already over
  13. no profit
  14. griefing here

Edit (5 minutes later):
After restarting the game and fiddling some more with quality upgrade UI I cannot seem to reproduce this. After adding treasures to the bucket upon reaching or surpassing 100% combined upgrade chance the quality meter rises already and turns green right away. Upon removal a treasure it drops back, but re-adding one turns it green again. None of this happened on my initial try I described above. It stayed lower and orange no matter what I did.

Hey @postscripter8 I checked your account logs and found that Silver Necropolis was actually at Hoard Quality 5 before you sacrificed the Sacred Treasure and 2x King’s Crowns, so it went to Quality 6 successfully.

Hello @Kafka, thanks for checking it for me.
Maybe indeed I was seeing things, but I was really paying close attention to the numbers… (hence my really detailed description above)

I have no undeniable evidence things went exactly as I remembered.
Also I don’t think you would have lied to me about such a thing.
I’m having a hard time accepting the reality, guess I’m gonna be forever suspicious of all the delve stuff from now on.

Thanks again for help, have a nice day.