Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Not a Bug] Epic Task embellishment is using not-so-epic resolution

Platform, device version and operating system:
iOS, iPhone 7, iOS 13.3

Screenshot or image:
IMG_2852

What you were expecting to happen, and what actually happened:
Modern devices have very high resolution displays, upwards of 200ppi. This looks more like the art from a classic Sierra adventure game scaled up from SVGA. It looks blurry at natural resolution and sad when zoomed. You probably forgot to set up which art gets used at what resolution for this widget.

How often does this happen? When did it begin happening?
It happens every time I look at epic tasks.

Steps to make it happen again

Look at epic tasks.

edit

Ugh I’m a dork and wanted the title edited and didn’t notice I can edit my own titles, so I flagged my own post to make the request. Everybody point and laugh!

2 Likes

I think you’ll find you’re not looking at it the way they intended.

2 Likes

Here’s the embellishment on a troop, for comparison, at higher zoom, Thomas:

IMG_2512

Unless the way you think I’m supposed to look at it is “from 30 feet away” I think there’s a discrepancy.

Oh, also, this low-quality image has been there since at least 4.6:

Screenshot 2019-12-16 at 10.26.34 PM

You might have to put on your readers to see the difference.

What graphics settings do you use on your device? I keep my phone set to “low”, and I’ve found that some egregious low-res images are affected by that setting if I changed it. Can’t recall offhand which ones, but I know it happened.

Edit: wouldn’t you know, changing my phone’s graphics setting makes those exact epic flairs look prettier!

Actually – thank you for reminding me – the Guild Leader management options (Promote, Demote, Kick) have terrible resolution on the Low graphics setting on mobile, similar to the above images. It does seem pretty disproportionate.

Huh, yeah, this is it. I hadn’t looked at those settings in a long time and apparently I was using “Low”. “Medium” is a bit better but seeing it change with the settings makes it “not a bug”. I’m going to try “High” and see if that kills my phone in gameplay.

That makes it “not a bug”, if not weird that only some things are blurry. I can see a design argument for “there are consequences if we make gems or kingdom crests too blurry but you’ll probably live if embellishments are low-res”.

I am not sure if I would classify this as “not a bug”. Why just those elements that change resolution with the settings? Why any elements at all?

I think I’m on Low because I was having animation issues at High and this fixed it. I used to not use Low because it made the gems kind of fuzzy and I didn’t like that. But now I remember a few updates ago they mentioned tweaking it, I tried it, and liked it.

I guess it comes down to if low detail’s trying to save on file size of assets, CPU, or both. For file size, I’d have expected changing the quality to invoke a download, and it’d be settable before assets download on a new game.

So I think it’s performance, and I think that introduces a lot of balances. Like I said, you need to pick out fine detail in some game elements, but not all game elements. So I can imagine at some point they played a lot of, “What if we use a lower-res artifact on THIS?” and just eyeballed the difference. Or they randomly decided what was important. No clue.

I’m at least satisfied I understand there is a “why” and I can do something to affect it.