Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Not a Bug - Account Issue] Account doesn't exist and is also taken

Platform, device version and operating system:
Steam/Mobile

Screenshot or image:
Two screenshots submitted as tickets

What you were expecting to happen, and what actually happened:
I came back from a hiatus to log into my Steam account and it was gone. I had tied my mobile to it when I had lost my phone for a bit and had needed a break anyways so I left the account up for a while. When I came back, it said no account existed with the name I entered (it was entered correctly and I tried it several times). I called it a day and went to load up a new account, got through the tutorial, and it said the e-mail I wanted to register was already taken. I’m bummed because I had VIP levels on my steam account and it would be great to get some of the stuff I already pulled!

How often does this happen? When did it begin happening?
Just the once, but I did try it multiple times in multiple ways and it’s both taken and gone at the same time. I also tried to click a link in an old password recovery e-mail sent to the account but it put up an error (no pending e-mail to validate).

Steps to make it happen again
Unsure.

According to your invite code, the account is being actively played. So if you gave your account away, the individual can reregister your account to match their info. This is why the devs advise never to give out such information to other people.

awryan, not the one linked to this forum, that’s my mobile but I was trying to recover my steam account that I haven’t been into or given anyone the credentials for.

The mobile account works on the Steam Platform.
If you mean your actual steam account is inaccessible and not your Gems of War account. Then you’ll have to get in touch with Valve’s customer support. Infinity Plus 2 can only help you with Gems of War accounts.
If you have a mobile account and a PC account then support will address your matter in the actual ticket.

I have 2 accounts, one on mobile, one on steam. The steam one is the one that says both my e-mail address is registered so I can’t use it as well as saying it doesn’t exist for password recovery.

1 Like

Hey,

If you’ve already sent a support ticket, I’ve sent you a reply.

If you haven’t sent us a ticket yet please do so using this link:
https://gemsofwar.zendesk.com/hc/en-us/requests/new?ticket_form_id=360000013555

1 Like

Yes! Thank you, Kafka, I meant to get on and reply sooner but I was stuck on my account all day grinding out the raid boss. All is resolved!

2 Likes