New Legendary Ascension bug [SOLVED]

What you were expecting to happen, and what actually happened?
So I went for 6 Artemas today in the Event Chest so I could ascend it to mythic.
When I try to ascend her an Error message comes up, I decide to restart the
game after the same error message turns up twice. When I log in again, I have
only 5 Artemas, and cannot ascend her to mythic…
@Nimhain @Saltypatra

What are the steps to make it happen again?

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!
Before:

After:

I will send in a ticket too, soonish!

1 Like

Edit: Never mind; didn’t read through entire post

In the past, the “troop inconsistency” error meant the ascension went through, but didn’t display graphically for me. The problem went away after restarting the game.

1 Like

Luckly I took a SS of the error, tho…

Restarted again, only have 5 troops of her, when it should be 6.

Ticket was sent yesterday. Im hoping to get help soon. :slight_smile: