Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[NEED MORE INFO] Game freezes when casting

Platform, device version and operating system:
Steam, Windows 10

Screenshot or image:

What you were expecting to happen, and what actually happened:
Game randomly gets stuck AFTER I click on Cast. The soundtrack keeps playing, but the screen remains frozen on the Cast screen. Can’t target, can’t do anything else other than quit the game…

How often does this happen? When did it begin happening?
This happened yesterday and today with High King Irongut while doing delves. In the past weeks though it has been happening with random troops as well - Rowanne, Queen Beetrix etc. As such, it doesn’t seem to be connected to a certain troop.
It just randomly happens several times / week, for the past 2-3 months.

Steps to make it happen again
No idea how to recreate it, as it seems very random. I never had this issue on my phone, though, so it’s clearly a Steam version issue. Yes, I did check the integrity of the files.

1 Like

Might be an issue, that you’re clicking “cast” to fast?
There’s that known issue:

“Some PC/mobile players are unable to select a target for their spell if they select the cast button too quickly after it becomes available.”

That sure sounds like a bug to me. One that needs to be recognized. One that the devs need to be reminded of, especially if it’s a known issue. And one that, in an ideal world, would be solved, sooner or later…

“Known issue” is a term used by devs for bugs that are known, but that haven’t been fixed yet (or fixing them isn’t easy).

I have a few further questions. :slight_smile:

  1. What is your device? You’ve mentioned Steam and Windows, but the device you are playing on.

  2. How often does this occur?

  3. How long as your play sessions when this happens, and how many background processes do you run at the same time?

1 Like
  1. Alienware m15 R3. Win 10 64 bit, Intel® Core™ i7-8750H, NVIDIA® GeForce® GTX 1070 Max-Q -Design with 8 GB GDDR5

  2. Twice in the past 3 days. 2-4 times/week in the past 2-3 months. It was not happening before, in over a year of playing the game.

  3. I run a minimal number of processes in parallel, other than my browsers.
    On the rare occasions when I was running multiple stuff in parallel and moving back and forth between the 2 screens and apps - I never had this issue. So, I’m excluding this as a possible reason.

When during the play session? It’s random. Yesterday I was doing the delves first thing and it happened in the third delve. The day before it was a longer session, it happened later in the session.

Another thing that was consistent every single time this happened: activity on both graphic cards briefly drops to 0 when the game freezes (clearly visible in the Task Manager). Important to note - screens do not go black, so there is little chance for the graphics drivers to crash. Plus, the animations in the background (and the sound) in GoW are still playing. I just can’t do anything in game. Went a step further and checked - no driver crash log in Windows Event Viewer.
No other graphic card issues with any other application/game. Even with ones that are waaaaay more resource intensive than GoW.
Drivers and Win are up to date.

And it happened again - this time in a pet battle, 4th battle in the session.
This is what I meant by the graphics cards:

image

And it happened again - but this time, game also closed, right after freezing… Things are getting better and better :))

Could you please let us know how long your general play sessions are?

Unrelated question, how do you manage to activate the UHD graphics along with a graphics card?

@Saltypatra it varies - from few quick sessions (10-15 minutes) to maybe 1-2 hours when there are events going on. But as I mentioned in one of my earlier replies, I did not notice any pattern in terms of session length - sometimes it happens right at the beginning, sometimes after a long play period.

I’m not sure I understand the question - UHD will always be active as the default card. The dedicated graphics card can be chosen for certain applications - either manually, or you can just let the drivers do their magic and detect automatically what the best situation for this is. But even if the dedicated card is active, the integrated one will also be involved.

Important aspect (maybe, not sure) - I’m on a laptop.

Update - for the first time now, game crashed outside of a battle (on the daily dungeon offer screen) and not when casting. Exact same process/steps, though.
So, this is DEFINITELY not the previously reported bug relate to clicking on cast too fast after clicking on the troop!

this been like that since the last update and them devs not going to bother fixing it crashes, freezes whatever bugs they planted on it. restart, uninstalled and back whatever you do to the console wont fix a thing on all platforms.

We still haven’t been able to reproduce this on a number of PCs with different specs. I know it’s a silly question, but have you updated all your drivers just in case?