My Chat doesn't work

@Sirrian @Nimhain @Alpheon

I’ve posted about this two times and never got any reply or fix. My Chat hasn’t worked properly for 8 months! I made a ticket through 505games and they said it’s a known issue and linked me to a post from march. Chat Server Down on console

As you can see a few posts down Nimhain states chat was fixed.

My posts in the known issues:

So just to be clear, you are still seeing the loading wheel when you attempt to connect to chat occasionally, and it doesn’t go away? Is there any more information you’re able to give us?

Yes. Rarely I see the global chat text when on the world map. That is the only time clicking chat does not give me the infinite loading wheel.

@Alpheon Is there any specific information that would help?

My internet is fast and stable. I play other games online with no problems. shows about 950Mb/s dl and ul and 2ms ping. My xbox network says 416 Mb/s dl 93Mb/s ul and 33ms ping.

I’ve reinstalled the game many times and tried doing a hard shutdown to clear the cache.

Do you have strict firewall settings that may block ports unless you allow them? How long generally do you wait with the wheel up for it to connect? You’re on Xbox I believe?

I’m on the xbox.

My router’s firewall is just on the default setting. I’ve never blocked or had to open any ports.

I have waited up to 30 minutes for the load wheel and it never goes away. I’m unable to move my cursor or bring up the settings. The only thing I can do is use the home button to go to the dashboard and quit the game.

A few updates ago, we added the ability to back out of the loading wheel when connecting to chat, however I’m guessing you’re unable to back out using the B button while the loading wheel is up?

Have you been in the same guild the entire duration of your problem? Do you know of any other guild members that are experiencing your issue?

I’m not able to back out of the loading wheel.

I changed guilds a few weeks ago. I’m not aware of any other guild members having trouble with Chat. I had the same problem with chat before joining.

I’m in the same guild as @Athrillskr right now. Similar to what he has reported, my in-game Chat appears to load only 20% of the time. It’s actually the Guild Chat backlog that fails to initiate whenever I log in. I can’t see messages OR the general announcement displayed.

What’s particularly odd is that this is happening mostly on my VIP5 account. The other Gems account on my XB1 console occasionally fail to load Chat, but that’s rare compared to the frequency at which I’m not seeing in-game Chat. :disappointed:

1 Like

Hopefully they’ll be able to fix these for you guys soon! Sorry to hear that you’re both having problems still!

@Alpheon They’re both in the same guild as me, so I’ll try to make sure if any important chat topics come up, to message them both directly about them in the meantime. :slightly_smiling_face:


I believe we have found the issue in regards to locking up the game when you get an infinite loading wheel, but we’re still investigating why it is having trouble connecting.


My chat has not worked for months, I’ve given up on it actually working again :laughing: I’m on PS4 and although I can bring up the chat box, no functions work at all. I have no idea what caused it.

@Alpheon Did you already implement this? My Chat seems to be working now!

1 Like

Ah, that’s excellent. Please let us know if it does occur again.

@mld-81: Are you still experiencing this issue as well? Would you be able to try to connect to chat once again when you get a chance and let us know what happens?


I am at work at the moment but will have a look again when I log on later today.

1 Like


My chat consistently worked Friday through Sunday. Yesterday and today it hasn’t worked at all.

Edit: Is it possible that the server rollback for guild wars removed your fix for my chat?

@Alpheon well it appears to be working again. I had to go into guild chat and play around with the settings, no idea how it broke itself in the first place

I don’t believe so, I think we still need to look into it further. Are you able to connect to chat consistently reliably on a PC or mobile device when you attempt to connect on your Xbox?

@mld-81: That’s good to hear! Let us know if it comes up again. If it does, would you also be able to check against a PC or mobile device to see if you could connect?

I don’t understand your question. Are you asking if I am able to use chat on the pc or mobile version of gow? If so, yes, I have no trouble using chat on the mobile version using the same internet connection as my xbox.

Edit: Are you talking about the Xbox app? I just tried it and my in game chat is working at the moment.


My chat worked a few times while I was running the Xbox app. Oddly there was no global chat. Only guild chat.

The chat is back to mostly crashing my game. I get the infinite loading wheel and can’t back out. I’ve restarted the game about ten times today. I tried experimenting with opening and closing the Xbox app. Doing either causes a short audio stutter. One time I closed the xbox app and started it back up and i got the global text on my screen. I was able to open chat. My Chat hasn’t worked since then.