Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[MORE REPORTS WOULD BE GREAT] Quality 10 hoard not displaying correct rewards

Platform, device version and operating system:
Steam, windows 10

Screenshot or image:

What you were expecting to happen, and what actually happened:
Hoard Quality level is 10, so all rewards should be available however, sometimes correct rewards do not show up on the card.

How often does this happen? When did it begin happening?
This happens during weekend Delve events, and has been happening for the last few delve events.

Steps to make it happen again
Easiest way to trigger bug is to exit the weekend delve event, go to the delve on the underword map. click on one of the rooms, then return to the weekend delve event and the incorrect rewards will be displayed.

I have also had it trigger when upgrading the hoard levels before completing the floor.
(complete a room, exit the weekend event and upgrade the hoard level, return to the weekend event, and the cards are showing the incorrect values)

1 Like

Thanks for reporting this. Is anyone else having this issue? If so, please let us know.

Can confirm. Steps to reproduce are exactly as OP says:

  1. Look at any room in Faction Assault event (tuesday or weekend), see 4 rewards (ok)
  2. Look at any room in normal daily delve, see 3 rewards (ok)
  3. Look at any room in Faction Assault event, see 3 rewards (last one is not visible)

After that, only way to get 4 rewards to show is client restart. Step 1 is mandatory, just doing normal delve → event delve does not cause problem.

It is only visual issue, all rewards are given after victory.