Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[More info needed] Tapping "Home Button" no longer works

Platform, device version and operating system:
Samsung Galaxy S9+, Android Version 10
Screenshot or image:


(The middle button on the right hand of the screen)
What you were expecting to happen, and what actually happened:
Selecting the “Home Button” is supposed to exit the game and bring me back to my home screen on my phone. Updated to Android 10 this morning and the button is registering but not exiting the game anymore. Now have to drag down on the edge to make the home button appear.
I’m going to mess with settings to see if it’s an interaction option. (Update, I can’t seem to find one. So it must be up to the app to decide how the “home button” will work.)

I just noticed that when on a menu like Tower of Doom, hitting the home button is mimicking what a back button would do. It’s at the world map or settings where it stalls out now.

A post was split to a new topic: Gesture menus not working properly on iPhone X

I’ve split the iOS issue into a new bug report thread.

@awryan I just had a play around on an S10 with Android 10 installed and the home button was working on the loading screen, in an Explore battle, on the world map, in the settings menu and in the Tower of Doom menu.

When I open the Android GUI by dragging on the edge of the phone and press the home button it takes me straight to the phone’s home screen.

It sounds like you’ve already checked these settings out but just in case you missed something there might be something helpful in here:

I use a Google Pixel 3XL with fully up to date Android 10 (Feb update atm) and it works for me. I use it a fair bit actually.

I tried to express that in the OP. I didn’t have to do any additional steps prior to the Android 10 update. I could select the home button without it appearing on the screen. Now I can’t.

Hopefully this video helps show what’s going on better.


On Android 9.0 (and all prior versions, including a time when the 3 buttons were stagnant). I could hit the home button and be taken to my home screen.
Android 10.0 changed that interaction.
Now it’s all just muscle memory so I have no doubt that after a while I’ll get used to having to make the 3 buttons appear on the screen before I’m able to exit the game. As Smash has indicated that he’s accustomed to already.
But of course my preference is to have the game interact like it did yesterday. Knowing that y’all didn’t change anything about it. Yet, originally the programmers must have intended for the home button to exit out of GoW originally without needing the drop down menu.
@Kafka

And thanks for the article…I read it and checked my settings… again. Even the developers options on my phone. I appear to have zero control as to how my home button interacts with the phone or game.

I don’t have any other games to test the interaction with on my phone. Besides Xcloud.


(I chose Bloodstained to avoid any issues with other games since it’s a 505 Game as well.)
I don’t remember how the button interacted prior to Android 10. But currently the home button acts as exit prompt if used directly (most likely incase it’s pressed accidentally). And then bringing up the 3 button layout and hitting the home button acts as a hard exit.
So it definitely appears to be up to the developers discretion and could be just as simple as “button mapping”. :man_shrugging:

Had an asset download right before reset and now my “home button” is working again!
Thanks, Dad! :grinning: (@Sirrian)

@Kafka
The home button isn’t working “like it should” again.
It’s possible it started being wonky again after weekly reset. But I just noticed it just now.

4.8 did not fix the issue.

I need to clarify if this is the actual issue:

The home button isn’t on the screen but when you select the spot it would be in if you swiped to bring up the menu it doesn’t take you to the home screen?

I’m confused because I wouldn’t expect you to report this as a bug so I’m sure there’s a misunderstanding here ^_^;

This button in the red circle… Is supposed to take me to the home screen of my phone without having to make it appear on screen.


Think of it like a magic button that acts without any prompts other than your thumb holding it down.
As explained before… Prior to Android 10 update the button worked fine for years with GoW.
Then I reported the 100% bug to you. Then you told Sirrian about it. A few days later a patch to fix the button was released. Then it worked like it was supposed to for a week. After weekly reset it reverted back to having to drop down the menu to access the “home button”.
Let’s use a metaphor to explain the issue.
For years you drive a car that you hold a button down to start it.
Then your car does an update afterwards the push button doesn’t work without putting a key in.
You let the car maker know… The car maker fixes it temporarily and makes it so the key is no longer needed to push start.
After a week the key is needed again. Because? :man_shrugging:
You explain exactly what had happened to the same exact employee of the car company and now they don’t know what you’re talking about…
I think it’s time I buy a different car. :+1:

We actually didn’t patch this at all, I believe it’s something to do with Android but we’ll do more testing.

I swear…
I had an asset download prior to weekly reset 11 days ago. The home button worked without needing to drop down the menu after the download.
Then sometime after the most recent weekly reset.
It went back to needing the button to appear to make it work.
My phone hasn’t done any updates since the update to Android 10.

Reminder to replicate the bug.
Use an Samsung S9+.
Open Gems of War. Without doing anything else. Hold down where the “home button” would be. You’ll feel feedback but basically nothing happens.
Then make the home button appear and select it. You’ll see your phone home screen.
The result of pressing home button in the second scenario is supposed to be the same result in the first scenario.
When using Gems of War. It shouldn’t be necessary to make the home button visible just to get it to work appropriately.