Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[More info needed] Gems of War Map Bug

This video describes the bug.
It’s annoying, i think it started with the last update or the one before that.
Can someone fix this?
I tried everything in the options and graphics but nothing happens.
Please help. I’m playing this game since more than 2 years.

Oh that’s annoying, sorry you’re having this issue!

Which device are you playing on?

2 Likes

On PC Windows 10.
Reinstalling the game on my computer didn’t fix the problem.
On my mobile phone it is working as expected.
Thank you for your comment.

Not a dev and @Kafka would obviously know more, just throwing some ideas at there for you @Amonin in the meantime. :crossed_fingers: It kinda looks like your game is receiving two inputs.

Do you have two mice by chance? Even if you use one, maybe theres a second mouse connected via bluetooth?

If only one mouse, could it be broken? Do you have a second mouse to test with?

Do you have a stuck key on your keyboard that’s interfering with mouse input? Try disconnecting your keyboard and move on the map, see if it works.

@Snooj My mouse is a razer viper mini with cable - no second mouse attached. I also tried it with my boyfriends mouse (logitech) and had the same issue. He played gems of war too recently on desktop and does not have the same issue so perhaps it is not hardware related, as there is no interfering keyboard input messing with the input system.

Could you ask a developer if he can give instructions in how to enable a debugging mode with verbose logging to figure out what is wrong here?

He is a software developer too, so following the instructions should not be an issue.

I am not a dev for GoW so I cant help with debug mode. :frowning: I was just hoping it was a hardware issue. Darn. I’m not sure.

Asked my husband who is a unity game dev if he has thoughts. He suggests updating your mouse drivers @Amonin.

He says the game is correctly detecting your cursor, but scrolling is broken. He thinks it may be a bug in the game, but is fine for most cases just not yours for some reason, so you are triggering some bizarre edge case. Drivers come to mind.

Another idea: The game may be scaling down your scroll distance, but not move distance. If you’re in full screen, try windowed. If you’re in windowed, try full screen. Also try different resolution sizes. It may also be an issue with 4k monitors if thats what you have, try on your boyfriend’s monitor with whatever resolution settings he uses.

Disclaimer: my husband and I are NOT GoW devs. Just posting ideas to hopefully help out. Not trying to step on Kafka’s toes.

1 Like

Same is happening to me, I sent a ticket but no reply yet. I’m at a lost on what is causing this issue

I think @Snooj might be onto something, so please try reinstalling your cursor/mouse drivers and different resolutions to see if it helps the problem.

1 Like

(SOLVED)
Tested and found out what the issue is. My Monitor has G-Sync since G-Sync monitors are affordable now of days I picked one up, so I disabled G-Sync and it works fine. Then I closed the game and put G-Sync back on again to test if it would slow down the game map and it did not??? and that’s strange in it self.

I did reply to the ticket to let customer service know and for them to forward this issue to the Devs for a future patch. Overtime many other people will have this issue if they upgrade to a monitor that happens to have G-Sync, not sure if this would also cause a issue with AMD freesync monitors.

1 Like

@Saltypatra unfortunately none of that did end up working. It is actually what we tried changing to begin (monitor resolutions) with but it made no difference.

The drivers are updated automatically through the razer software. So if it is an issue with the mouse driver i would suggest GOW gets in touch with razer, since the only game i am having any issues with is this one. In other games i never experienced any similar issues.

Disabling G-Sync was not an option on my nvidia control panel (monitor does not seem to support it), so that should not be the cause either