Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[More info needed] Equipping pets freezes the game

Platform, device version and operating system:
win7
Screenshot or image:

What you were expecting to happen, and what actually happened:
Game to continue, computer says no.
How often does this happen? When did it begin happening?
Began with Shaman with Joust Mouse equipped, Forest of Thorns (Power level 18) kingdom screen, -> Power -> Collect 3 pets (finished) -> equip Dire Rose (mythic) -> go to previous screen -> game locks down (buttons flash but wont work).
Also after reloading the game i tried with Shaman & Dire Rose -> Sword Edge -> Minito Mori (lock down) and Shaman & Minito Mori -> Whitehelm -> Peace Pigeon (lock down).

If you are equipping a pet, go to a kingdom different from your equipped pet and one that has a pet quantity or pet upgrades in their power level upgrade demands, unfinished or finished, click “the pet demands” and from your roster equip a new pet, then back up one step and the game stops working.
Steps to make it happen again
Quo vadis ? back up one paragraph.

Hey I tried this out and couldn’t reproduce the issue.
Did you have the game open for long before you noticed this issue?
What were you doing in the game before the issue happened?

A few, a couple of, but hours anyway.
I checked this once again as follows: (Did Stonesong faction daily delves), surfaced, went to a Kingdom (at random it was Zhul’Kari) -> Power -> unfinished troop demand -> Pets -> (at random or at this time it was cosmetic pet from Broken Spire) equip a pet and unequip it, -> back up . Here the game sends you back to the “job list” window that is under the kingdom Power button and where you checked the unfinished troops demand. And then locks you out.
Same result with Whitehelm & Baby Beard.
And Pan’s Vale & Black Beast-kin.
And these are all random pairs.