[Known Issue - more info needed] Solid white/black boxes instead of art

No, I still see an empty image on Skelly Cat.
And I’m sorry, I’m not going to clear app data / reinstall, because it’s not just about one missing image, it’s about disappearing images during the battle as well. This won’t be fixed by a reinstall. Like this: (one screenshot from weekend Bounty, another from PvP).


Hello :slight_smile:

Unfortunately, if you would like to ensure that your device has received the fix/changes the developer working on this issue has made, please do clear data / cache at the very least if you are unwilling to uninstall and reinstall Gems of War.

(You won’t lose progress in the game if you remember your account details - especially the invite code.)

1 Like

Oh, I cleared app cache. You see the result above :smiley:

Clearing app data deletes a lot of data (over 1 GB), that will have to be re-downloaded. The missing & disappearing images issue has been on-going for months, so I refuse to do it every week to fix one image (which won’t fix disappearing hero & other images that are disappearing mid-battle), I’d like to see a permanent fix.


I wrote this multiple times, it feels like I’m a broken record. You’re not listening, or you don’t want to acknowledge the problem. So, @Bramble , once again:

This is not about Skelly Cat - this missing image annoyed me for the entire weekend, when the bounty event was in progress. Now I couldn’t care less whether it has an image or not - it doesn’t belong in my teams. Yes, I’d love for the issue never to repeat with future events and future troops, but this is not the main problem I keep facing.

This is about the fact that I enter the battle with full set of images visible on both sides - so the images ARE THERE. And working. No pitchfork. But 10, 15, 30 seconds into the battle (especially if there’s a raven or a gnome crashing the battle, but not only) something GLITCHES, the game freezes for a fraction of a second, and then: hero image disappears, leaving only background behind. Or the entire troop art of the crasher goes white. Or black. Or turns into white-grey pixels. Or my hero’s clothes disappear, or background on hero card disappears. Both on my side and on enemy side. The same glitches happen in many other places in the game - in troops menu, on battle start screen… the images are there one second and disappear the next. THIS won’t be solved by clearing any sort of data - this needs a client update and a fix on your side. That’s why I refuse to clear all data / uninstall / reinstall - unless you tell me that this problem will be 100% fixed by doing so.

Before the December (I think) update, all eight troops would go black or white for weeks, in nearly every battle. Now it’s only hero & crashers, and sometimes mythics, but I still want the issue to be solved, because THIS is what’s making it very unpleasant to play on the phone. Android, btw.

So please, don’t say “you can’t help me”. I’m willing to do the steps, if I believe they will help. But I’m 99% sure those steps won’t help with the images going blank - so here I am, waiting, for a permanent fix to disappearing images, which are there at times, and then they disappear.


Some more examples, from a few minutes ago, because I’m really, really tired of this problem. Start of battle, two moves in (see the hero background just go white?), and Vault battle start screen.

Tell me, will this be solved by clearing app data? Or reinstalling? (i cleared cache, it didn’t change a thing.)


Hey @Dwuemka this is a separate issue (as you’ve mentioned) which we’re also looking into, sorry for the mix up in the other thread. I’ve split your posts out from the other issue’s thread into a new one so we can keep them separate.

We’re currently looking into whether this is caused by a memory usage issue on some devices.

If I could get you to send me some additional information, we’ll check to see if your issue matches up with that theory as well or not. We’re trying to confirm by gathering this information from a number of players as well as checking for errors on the affected accounts from the back end.

You can post the information in this thread, DM me this information on the forum or send a support ticket, whichever is most convenient for you.

  • Invite code:
  • Device model
  • Android version


  • Open Gems of War and play until this error occurs
  • Keeping the game open in the background (don’t fully exit the game), open your device’s settings app
  • Select the option that says “Device Maintenance” or “Device care” (if these options aren’t available to you, we’ll need to get you to turn developer mode on so let me know)
  • Select “Memory”
  • Take a screenshot of the top of the list of apps that appear, please try to include the app with the most memory used and also Gems of War

I’ll do that, thank you for the quick response. One question, before I go on to gather the screenshots and the like - the issue appears on two accounts, two different phones - if I go through tne support ticket route, then separate tickets for each account, one for both, or maybe a message on the forums will be best, then? There might be some sensitive info on some of the phone screenshots that might be best not shared publicly.

1 Like