Khaziel last quest battle against evolved Gorgotha broken?

On Xbox One, when you reach the last quest step and battle the evolved Gorgotha, there is a problem. On the team select screen, you only see three opponents with the “scout” button covering them. Then, when you enter the battle, the gem field is completely blank, and the top of the board looks like the top of the treasure map board. The opponents cards are still messed up, and you have to exit to dashboard to get out of the battle screen. I tried this several times, always the same result. Is this a known issue?

No, but it has an easy avoidance; just don’t use the Scout button. They’ll fix it, trust me.

Does this only occur when you use the Scout button?

No, in fact, I never use the scout button. But for some reason, it shows up “stuck” on top of the opponents team cards (of which you only see three) before the battle begins.

I’m suffering the same issue. Is there any recommended course of action of is it a case of wait and see?

We think we may know what’s going wrong, but I’ll double check with @Alpheon and @GoldPhoenix0 when they get back into the office for the latest news for you.

I also ran into this bug today. I really want to explore for arcane deep traitstone. Hope this can get fixed soon!

Just adding my name to the chorus - I’m having the same issue and am unable to fight the final battle with Gorgotha. All attempts to clear the issue - restart game, reboot console, do something else and then return later - nothing works at this time. For the record, use of the Scout button has nothing to do with this problem - the screen where the scout button normally appears is already corrupted and unusable (as described by obi-juan) the moment it is displayed.

No, I’m afraid not PowerPlay - this issue isn’t related to the Scout button. The screen where the scout button is normally displayed is already corrupted and unusable the moment it is displayed, and in fact the problem makes it difficult if not impossible to press the Scout button because of the screen corruption. It IS possible to continue from there on to the battle, but the battle screen only partially displays and the battle cannot be played.

I have the exact same problem with this quest, “Defeat the evolved Gorgotha”.
On the troop select screen before the battle; the opponents team has the heading “Your Troops”, the telescope and word Scout are superimposed over the troops, there are x3 troops, x2 are obscured by the “scout” box, the first troop can use all mana and has a word or name ending in “nistm” that is behind the telescope and over the scout box but above the troops picture, the second troop is a Rock Worm and it’s name is behind the word Scout but over the scout box again, the third troop is a Ancient Horror, this name is above a x50 gold coins image!? When you go To Battle; the main arena is just a background image checker board, the top panel is a mixture of a normal fight header and a treasure map header, there are x4 troops, first x2 troops are both Rock Worms, third is a Ancint Horror, fourth has no monster image in its box but all status effects such as burning, freeze etc.
It’s very disappointing as, it’s my very final story quest out of all the kingdoms.

We believe we have found the cause of the problem, unfortunately it requires a client update to fix. Good news is that we’re still doing internal QA for the console version of 3.0, so it should go into that update.


It’s all fine on my Xbox One S now. Very pleased that it got fixed so quickly. Thx guys :slight_smile:

1 Like

Yes, all fixed for me too. Completed the quest last night with no problem. Thank you Nimhain for taking care of the issue so quickly!