[Investigating] Turning off autoplay can freeze game

Platform, device version and operating system:
Steam - Windows 10 Home
Screenshot or image:

What you were expecting to happen, and what actually happened:
Turned off autoplay in the middle of a move. As a result, the game froze, with the white target selector bouncing over the character’s head. Everything else is frozen. I expect the game to resume with human control.

How often does this happen? When did it begin happening?
Very rarely. It’s likely a race condition that involves specific timing as to when you’re disabling auto-play.

Steps to make it happen again
Enable autoplay.
Disable autoplay with particular timing.

Hey @JamesDurning

Attempting to repro this myself and not having luck, as I imagine this is very timing dependant.

  • What game speed do you play on?
  • Have you noticed this in any specific game mode?
  • Are you selecting to disable autoplay before a move is made and it’s switching off during the move or are you clicking disable as move is happening in the background?

Was trying to repro this last week and was unable. I’ve only seen this twice ever.
I generally play on 2x speed. In this one, I was doing Explore 12 in Khaziel.
I’m not sure if it was because of a double match?
To be honest, I’m not sure of the timing because I wasn’t paying attention. I’ve tried a bunch of timings, but haven’t yet been able to intentionally repro it.

Hey @JamesDurning

Thank you for providing those extra details and how efforts to repro the issue have gone. I’ve tried to reproduce this issue myself with the extra details you’ve provided and I’ve unfortunately not been able to trigger this issue.

Hopefully, this was a once off issue but we’re still investigating it. If you do happen to reproduce it again or have any extra details, please let us know :slight_smile:

OminousGMan - Support Human :male_detective: