[Investigating] New hesitation in play (short term) after the end of every battle

Platform, device version and operating system:
Samsung Galaxy Tab S6 Lite, model # SM-P610, Android version 12

Screenshot or image:
sorry, no rolling balls, no error #. Just a quick pause (2-3 sec) at the end of every battle

What you were expecting to happen, and what actually happened:

  • I expected the normal progression between the Victory symbol and the game rewards, or at least some rolling balls to signal that something is happening once in a while. Instead I’m getting this small lag/pause (seems to be the same length every time) after every battle for days now. This isn’t the usual sometimes-lagging, sometimes straight from victory to rewards behaviour that I’m used to.

  • what I’m finding odd is that it isn’t happening in any other game I play, and that I don’t see this behaviour on my iPad/iPhone.

How often does this happen? When did it begin happening?

  • it’s consistent, and happening every time I end a battle now. Started right after the 6.3 update. No particular game mode, happens every time no matter what game mode.

  • I’ve tried restarting the game and the tablet, but there isn’t any change.

Steps to make it happen again

  • play a battle.

i can confirm this issue myself ever since the latest update. it worked fine before that. now there is a 2-3 sec pause after the Victory screen and before the reward screen shows up. It only happens on my phone which is an android samsung phone. Works fine like before on Steam though.

it wouldn’t bother me that much but it becomes a big problem in Vault Weekend where every second is precious. i had to exclusively grind on Steam (PC) due to this issue so please consider fixing this in next update.


what team are you using? If it’s not the same team on both devices, the difference may be in the troop that lands the killing blow. I’ve done some testing between android and steam, and I have found that there is almost no delay at all when you win using rowanne for example, but with beetrix due to the gems created even after all enemies are dead, the board takes much longer to resolve and display the victory screen. I can’t detect a difference in that delay across platforms, but it’s definitely different between teams…

it is an issue with all teams. rowanne, skull spam teams, bee-venoxia, zul goth, etc. i use the same teams on both platforms and the issue is only on my android phone.

it started after the last update. i have been playing since jan of this year and this was never a problem. obviously they changed something in their code with this update. if i had to take a guess, it seems have to happened due to the Auto Play functionality added in which may have regressed existing functionality.

also, i have checked with other guild members and i am not alone. it is a problem due to the update and should be resolved.

1 Like

I find this happens with my Android tablet but not my Android phone, oddly

1 Like

It happens to me on Android too, but not on Steam. I play with the same teams on both platforms. I have noticed that once the last enemy is eliminated, the board stays for about 4-5 seconds, and sometimes the victory animation does not even appear and it goes directly to rewards. other times the victory animation stops in the middle and the 4 second block begins there.
It happens using autoplay and without using autoplay.
I don’t know if this information will help, but here it is.

the delay is between the victory screen and the posting of the rewards, so by that time the board has settled down. Would there still be anything to be resolved at that point? Because that’s what it feels like, as if something new has been added that causes the delay.