Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Investigating] Gems of War will still be running in the Task Manager, but the game would not start

Platform, device version and operating system:
PC - Steam client
4.7.0.05
Windows 7 HP SP1 (64-bit)

Screenshot or image:
Not available.

What were you expecting to happen, and what actually happened:
Gems of War is still running in the Task Manager. If I end the game manually, the game will not start, even if I restart it or run it again, clean Steam left-overs, and restart Steam. User Logout will not suffice. A complete PC restart is necessary in order to fix this issue. If I start the game again, even though it was shut down in the Task Manager, Steam will report the error that the game is already running, which is false. The game will also not show in the Taskbar.

Important:
It can also happen that the game is running, but you can’t enter it again if you use the ALT+TAB option.

Graphical settings are set to 16:9 - 1920x1080, Fullscreen, and V-sync activated.

How often does this happen? When did it begin happening?
Relatively rarely - 4/100 cases, but this issue only started happening since the last update, 10-14 days ago.

Steps to make it happen again:

  • Run Gems of War on PC - the Steam client.
  • Run it at least 100 times and hope to encounter this issue.

Hey @Koromac

Thanks for posting about this.

Can you please clarify some details further?

ie. when you say close manually, are you using the Quit button in the game settings menu, the windows X button in windowed mode, right clicking on the start bar and selecting “Close Window” or is this happening only when force closing the game from the Task Manager?

How long do you wait between exiting and re-opening when you have this issue?

How long have you tried waiting after receiving the error message “the game is already running” before trying to launch the game again?

Have you noticed anything else strange that might be related to this? (ie. other error messages, lag, blue screens etc)

2 Likes

I am using the mouse all the time, so yes, I select the Quit button in full-screen mode, because I never use a windowed mode. I tried to close the game from the Taskbar a few times, but the game did not respond or close, so I had to open the Task Manager to close it down manually. However, the Steam error was reporting “game already running”, so each time this happened, I had to restart the PC to eliminate the issue and resume normal operations.

I have waited over 15 minutes once, but it had no effect. The game was stuck in the Taskbar, minimized. I think this issue may be somehow related to the Unity engine, but that’s only my speculation so far.

Like I said, several times and more than long enough.
I waited 3-5 minutes, before trying to run the game again in-between.
My PC has 16 GB of RAM, 4 GB of VRAM, and an I7-Intel core (870 - 2,93 GHz).
There are no other performance or stability issues otherwise.

Nothing else, except that the game was shown again in the Task Manager again after being shut down manually, but didn’t re-open again and was not shown in the Taskbar. That’s why the only solution was to reboot my PC, start the Steam client with the Administration privileges, and the game, double-click on a desktop shortcut instead of a game client in the (game) Library section, but that’s not related to this issue.

I forgot to tell you that sometimes I ran the game on Steam without opening Steam first, even though it opens automatically when you start the game.

I am reporting here again to let you know that I just moved on to Win 10, so I can’t comment or test this issue any further. I had no such issues in Windows 10 so far.

If you can’t find the cause, leave it be, move on to solve (an)other bug/s.

Good luck, @Kafka

I have Windows 7 at home so will give it a test there thanks for the additional info.

1 Like