Lorem ipsum dolor sit amet, elit eget consectetuer adipiscing aenean dolor

[Investigating] Game Freeze in Training

Platform, device version and operating system:
Windows 10 and Android 8.1

Screenshot or image:
Here’s video from Android

…and here’s one from PC (sorry for it’s bad quality, I wasn’t sure how to use it to record the windowed mode)

What you were expecting to happen, and what actually happened:
I expect my training battle goes as normal battle, but I can’t match any gems.
The pulsing of hint gems is also weirdly fast. In addition, for PC, the card switch animation and info card change is also unusually fast.

How often does this happen? When did it begin happening?
So far it trigger 6/10 times on Android, 2/10 times on PC, 0/10 times on iOS.
It started when I tried this team
[6067,6423,1159,7041,3070,3,1,3,2,2,3,0,14008]
training against this team
[6614,6614,6614,6614,3000]

Steps to make it happen again
Use the team above in training. I haven’t test it with different defense team or different mode. I don’t know which team (or what) caused this.

1 Like

Nice catch.

Always happens to me (Windows, Steam) if I do this battle straight after game start. If I do any other battle first, everything is fine.

Also, if you add Werebat to enemy team, board freeze can sometimes happen on AI first turn, so it’s somewhat exploitable.

Wild guess, it’s caused by the Lycantrophy trait of Werebat, 50% chance to convert a Purple Gem to a Lycanthropy Gem at the start of my turn. Theory would be that it messes up the event stack whenever it happens on the very first turn, possibly based on other talents/traits/medals firing before it.

1.) Has anybody ever seen Werebat turning a purple gem into a Lycantrophy gem on the very first turn?
2.) Light Fingers also triggers at the start of the turn, does the game still get stuck without that talent?

If it helps my medals were 2 seasons and an anu.
I’ve been using stacks of Werebats in other game mode and they can trigger first turn no problem.
@zRrr mention it can happen with enemies too. If that team has a hero then maybe the class talent vs Werebat trait theory is the one to work with

This will sound weird, but TLDR is: If first battle in session has Werebat, there is a chance to throw exception during Lycanthropy trait check, boosted by number of pure brown AI troops.


4 Werebats vs 4 Coin Purses made it happen 10 restarts out of 10. 4 Werebats vs Coin Purse and 3 Cows - 3/10. Reinstalled GoW to SSD - same results. Other treasure troops are fine. Retreating and repeating same battle without client restart sometimes work, after that everything works fine until restart.

Tested on x0.25, x2 and x4 speed, nothing changes.

It related to Lycanthropy trait, because lycanthropy gems never show up. Also team of [Skadi, Werebat, Tink Steamwhistle, Werebat] ends up with blue storm, because turn start sequence aborts and Tink trait never procs.

Coin Purses can be replaced by other pure brown troops. Maybe hero with brown weapon also counts.

Spells, that don’t requre target on board (empowered, leprechaun - good, astral spirit - bad) can unstuck it, as usual, but on next turn everything repeats.

Also fun fact: Bright Forest Challenge 1 has [Deep Borer, Brownie, Rock Worm, Troglodyte]. Works fine there. Same team set as defence, triggers this bug in training.

2 Likes