[Investigating] Can I use Lesser Orb of Glory on untraited troop? Or not?

Platform, device version and operating system:


Screenshot or image:

What you were expecting to happen, and what actually happened:

When I try to use Lesser Orb of Glory on Euryali, who has only 1/3 trait unlocked, the game displayes the above error message …

And restarts. Isn’t it industry standard to consider a game restarting when the user merely attempts an illegal move as a “bug”?

But that’s not the end of the story. Weeks ago, I used a LOoG on Yasmine’s Chosen, who has 0/3 trait unlocked … and did get the Elite Level. Below picture clearly shows the troop with 0/3 trait unlocked but had bronze elite level.

How often does this happen? When did it begin happening?

The case with Euryali is repeatable. The case with Yasmine’s Chosen happened just that one time (the operation itself is not quite repeatable).

Steps to make it happen again

Attempt to use LOfG on a non-fully-traited troop to make something funny happen.


1.) Orbs of Glory are not supposed to work on troops until they have been fully upgraded.
2.) Unfortunately, this totally slipped through QA, so Orbs of Glory at first worked on troops not fully upgraded.
3.) More unfortunately, this was considered to affect monetization, so a sloppy band-aid got hammered into the upgrade menu as fast as possible. The point where it detects that the troop isn’t a valid target doesn’t support any negative outcome, so without spending effort to implement proper error handling the only option is to intentionally crash the game.
4.) Most unfortunately, the current state no longer affects monetization, so it will be considered solved to the fullest satisfaction of everyone, player experience be damned.