[Intended] 6.6.0 bug. Rotation locked

Hi @Jeto I just downloaded the new Halloween update on android and now the game won’t rotate 180. No matter what I do, it will just stay in one orientation on my phone.


Hey @gow

What device are you playing on? And is it stuck in portrait mode so the game is really small?

I just loaded up on my Pixel and it is displaying in landscape mode.

It is in landscape but it won’t rotate 180 degrees when I flip my phone. I am on note 10 plus. It used to rotate fine.

@Jeto I found that now I had to toggle rotation in my pulldown menu in order for the game to rotate 180 degress. It didn’t need that on before.

1 Like

Experiencing the same thing on Android 10.

Before 6.6: both landscape orientations worked, game would rotate to be upright as necessary, regardless of the Android auto-rotate setting. This was handy when I’m plugged in to charge from USB I I could choose whichever orientation kept the charge cable out of my way best.

On 6.6: it is locked to one landscape orientation unless I turn on the Android auto-rotate setting, so unless I turn that on it is upside-down in cases where it would have been correct before. This is not ideal for me; I like to keep the system auto-rotate setting turned off to keep Chrome and Twitter locked to portrait mode.


Same here. And pretty much the same reasons too.

My phone is Sony Xperia with Android 9.

1 Like

same here.
Screen will not rotate unless I enable auto-rotate in my phone’s settings.
Android 11, OnePlus 8 Pro

It works ok on my Galaxy S9+ without autorotate on.

Yeah, I’m in the same boat. Turning my phone’s auto rotate on works but isn’t ideal to have to turn it on just for GoW

Hey folks just an update.

Currently we have no plans to try to manually change this for a couple of reasons:

  • It’s not a Gems of War specific setting - we prefer not to mess around with things the game engine and Android set themselves as default.

  • If the screen is rotation locked it implies the rotation will be locked so we think bypassing these default settings may suit you folks here just fine (I can see where you’re coming from for sure) but might not be the expected behaviour for most users.

I will make this into a feedback thread so anyone can add their opinion on the topic and we can follow.

I mean, fine, but this is a change in behavior from 6.5 and from my perspective it’s a regression: the old behavior was useful.

1 Like

We updated our version of the game engine, Unity, during 6.6 development, so the settings may have changed in Unity.

Even when Auto-Rotate is off, things like a Youtube Video will adjust the 180º view while maintaining e.g. landscape so it’s not upside down… So the current GoW behaviour is beyond impractical and this

possibly misses the point that auto-rotate refers to landscape vs portrait.
:man_shrugging: :vulcan_salute:


Just tested this again with one of the in-game ads: the ad does rotate to the 180° alternative landscape mode, even with auto-rotate off…

…so if it is really ‘intended’ that GoW is stuck upside-down, it’s not only against common practice, it would seem to have been deliberately modified to stay in this arguably absurd mode.
:roll_eyes: :person_facepalming: :vulcan_salute: