Infinite rewards loop


#1

Platform, device version and operating system
PC Windows 10

Screenshot or image
Sorry, I exited before knowing a screenshot was needed

What you were expecting to happen, and what actually happened
I had just finished the “unquenchable flame” questline in in Suncrest. It kept prompting me to collect rewards for the task. Even when I tried to click the return button or the escape key on my keyboard. I ended up having to use the task manager to exit the game

How often does this happen? When did it begin happening?
Was this a once-off bug or has it been a consistent issue? Does it only happen after doing a particular game mode?
It only happened once, and only in the particular spot I mentioned above.

Steps to make it happen again
Do you know how to make this happen? Sometimes there are certain steps that can lead to a problem that may not be obvious!
I have not been able to make it happen again. I tried going back into that questline and it has moved on to the next quest.

I really just felt like I should let someone know, even though the issue resolved itself, because I gained an entire level of XP while trying to exit the screen. It felt extremely dishonest to not tell someone.


#2

I’ve had similar with being unable to leave the next fight… no idea if I was gaining rewards as well or not. Happened two maybe 3 times in the last couple of weeks


#3

Glad it’s not just me.


#4

Are you sure you got any extra rewards? The same bug happens in the Sentinels level up Screen in GW now, but you don’t actually spend any extra resources. Maybe it simply lets you click many times. Did you actually get extra rewards?

This is another common bug.

NowayJoe2Go


#5

I had something like that on Arena and yes, rewards got added. I was even able to donate the gold into guild tasks. It happened when I played while there were problems with servers. And everything went back to normal when I restarted the game.