In game shops not working

Hopefully, this is the right area for this. Anyway, to my problem!

For the past week or so, the GoW shop, flash offers, etc have just stopped working. It goes to the buy menu, I select it, then it acts like it cancels it out and goes back to the screen I was on previously. I’ve read the “fixes” for similar issues and have tried them, but no avail. Buying stuff with gems works just fine. Is this a known issue? If so, is there a fix?

Which platform do you play on?

Thought I mentioned it in the post! I’m on Xbox One.

1 Like

If you were on Android I thought maybe I could help. But Xbox is foreign to me in that regard.
My only suggestion is to make sure your credit card info on your Xbox account is accurate.
Otherwise, maybe a fresh install of the game will help.

I use an alternative method for buying things. I can confirm it’s accurate as I just purchased an item from the Microsoft store. Something is wonky with the gems of war purchases. I did a fresh install and it still happens. I’m not being charged for the purchases so it’s like it’s cancelling the transaction as I hit the buy option.

1 Like

I would do a “technical issue” ticket then. You’ll get faster help with it than posting about it on the forums.

1 Like

@Xandler I’ve had this issue also, and here’s the fix that works for me. Open the item and select the option to purchase it. You’ll see the Microsoft screen that has the option to buy or choose a payment method. Act like you are going to change your payment methods and simply select the option for your regular payment method again, and then when you return to the purchase screen, select the option to buy it, and it’ll process. Did this on both of my accounts yesterday for the flash sales.

1 Like

@CanyonSurfer That fix worked! Thanks so much. Is there a way to actually fix it completely that you’ve discovered so that extra step isn’t required since this is just a workaround?


@Xandler I’m not aware of any fix for it. Lots of people have had purchase issues for a while, and it seems to continue to be a “next update it’ll be fixed” answer. Glad that workaround worked for you :slight_smile: