How to take a screenshot on Unity on PC?

Yesterday, prior to update, I could click F12 due to Steam integration (shift-tab to bring up Steam interface). Now the Steam interface no longer works and neither does F12. I know alt-printscreen works but now I have to paste into paint, this is a significant downgrade imho.

1 Like

F12 for a Steam screenshot still works fine for me in the new version. Maybe it’s something specific to your setup?


If you are on windows 10 you can use the following:

Press the “Windows logo key + PrtScn.” On some laptops and other devices, you may need to press the “Windows logo key + Ctrl + PrtScn” or “Windows logo key + Fn + PrtScn” keys instead. Check your laptop’s manual for more information.

The screen will dim for a moment, and you will see the screenshot appear as a file in a folder entitled “Screenshots”, inside your default “Pictures” folder. The screenshot is automatically labeled with a number.

That is interesting… I am going to test this again and then reboot and screw with things. Thank you for letting me know your F12 still works.

1 Like

@Amadan Thank you.
So I played with it, when I launch the game from my start bar with a pinned shortcut F12 does not work.
When I launch the game from the steam client (pain in the butt) F12 then works.

Edit: Did some more playing.
When I use the shortcut on my desktop the F12 key works for screen shots.
During the same session where F12 is working, I option to pin this application to my start bar. Quit GoW, lauch from my start bar and F12 no longer works. Exit GoW, launch from the desktop and F12 works again.

1 Like

Now THAT’S funky. For what it’s worth, I launch it by right-clicking the steam icon in the task bar then selecting Gems from the popup menu.

Pretty damn irritating… But that is what Unity is all about, we all find Unity in disliking a lot of the crap in Unity.

Hey, anything Not Adobe is a billion times better than anything Adobe. ;p

1 Like

While I agree there is some nifty stuff here with the Unity upgrade and I agree that I cannot blame Unity for the poor implementation of so many things (this topic is one glaring issue).

Whoops… I did not mean this topic… I meant this one:

1 Like

There is a nontrivial workaround to that issue.

In your Steam library, right click on Gems of War->Properties, then click on Create desktop shortcut. This shortcut opens the game via URL. You can move this link where you prefer.

Most likely, you won’t be able to drag/pin this shortcut to the taskbar, but you can modify the old shortcut so that it targets the internet shortcut rather than the .exe file. (Right click on icon->right click on GemsOfWar->Properties->Shortcut, replace target path. Be sure that it points to shortcutName.url.)

1 Like

Thank you @nemesis , I think I am just going to launch from Steam from now on, the change in procedure is not that big a deal, figuring it out was traumatic though…:slight_smile:

1 Like