Hero Area / Guild Task Interaction Glitch


#1

To be clear, this is a graphical glitch only and everything still works

From the main map area, I clicked on the hero button (as in, button right of the screen) while the guild button was indicating tasks were ready (with the flashing exclamation mark). Upon returning to the main map, the guild button was in its usual state instead. Opening the guild area didn’t display the completed tasks.

What you were expecting to happen, and what actually happened?
I expected returning to the main map to still have the guild button flashing, and opening up the guild area to display finished tasks. Instead, nothing happened after I went to the hero area. It does seem to still be rewarding me, so it would appear to be a graphical glitch only - simply very misleading and potentially panic-inducing.

What are the steps to make it happen again?
Requires two people in the same guild. One finishes a task in the guild. The other goes to the main map, has the guild flash at them, opens up the hero area, exits back to the map - guild may no longer be flashing at them - and open up the guild area to try to see the tasks completed.

Do you have any screenshots or video you want to share with us so we can see the problem? Attach them to your post!
No recording. If super necessary, I can try to get video. Screenshots wouldn’t really do the trick.


#2

Also experiencing this same glitch, but with 1.0.8 so close to release I’d chosen to simply ignore it and see if the next patch fixes things.

:warning: :construction:


#3

Same here ----------


#4

Only found it today, its probably been there for ages. Who goes to the hero section when there’s loot to collect??