Guild Wars Team Exchange Bug

#1

What you were expecting to happen, and what actually happened:
Played the first Guild Wars battle today with my pure red team, winning easily. The victory screen then changed the team to the Explore team I had been playing previously, granting much less points due to mismatched colors.

Steps to make it happen again
Not sure, the only uncommon thing I did between Explore and Guild Wars was reconnecting to the chat. Whatever is causing it, it can likely be exploited in an inverse way, playing Guild Wars with an easy mixed color team, then getting credit for a matched color team to significantly improve scores.

3 Likes
GW Points are lower than normal
Teams swapped in match Alg
Guild Wars Team Score Bug - Free to Exploit?
#2

Adding a bit more info to make this easier to sift through in the logs.

  • Had a daily quest for 3 battles with 4 troops of the same kingdom.
  • Adjusted my team “Daily” to Dawnbringer/Warlord, Rhynaggor, Infernus, Gob-Chomper.
  • Completed the daily quest by exploring Khaziel.
  • Possibly reconnected to the chat at this point.
  • Entered Guild Wars, scouted the first team.
  • Picked my team “Red” containing Dragon Soul, Dawnbringer/Frostmage, Ketras, Moloch.
  • Backed out of my picked team, looked through my team list, then repicked team “Red”.
  • Played the first battle in just a few turns due to a good board. Ketras did most of the work with his spell.
  • Noticed that something was wrong when the victory screen awarded champion xp for the Warlord class.
  • Scrolled through the reward list, saw that I had only received 29xx points.
  • Backed out, checked the guild overview in hopes this would only be a display bug, it also only showed 29xx points awarded.
  • Opened this bug ticket.
  • Restarted the game, entered Guild Wars, team “Daily” came preselected.
  • Switched to team “Red”, the remaining fights worked correctly.

Thoughts:
How the hell could the played team “Red” get treated as team “Daily” for battle result purposes?

1.) The client somehow reported team “Daily” as part of the battle result to the server. Assuming that this also includes a battle transcript as tamper protection this should have raised all kinds of red flags on server side, because the team “Daily” and the transcript “Red” couldn’t possibly have matched.

2.) The server somehow decided to ignore the battle result of team “Red” and treated the fight as if done by team “Daily”.

Please look into this, whatever the trigger might be. This is very, very likely just the tip of the huge iceberg showing, there’s so many ways this could be exploited for great gain, in several game modes, I’d be extremely surprised if that isn’t happening already.

4 Likes
#3

Hey there! Sorry this happened :frowning:
Were you online over reset?
Was there any other unusual lag or connection issues at the time?

#4

No, I played that match roughly 13 hours after daily reset, the game was online for roughly 3 hours at that point. There also wasn’t anything else unusual except the part about reconnecting to chat. On a very wild guess the game somehow got confused by me picking a team, backing out and picking it again. If wasting Guild Wars sigils wouldn’t hurt guild placement so much I’d probably poke the issue some more.

That still doesn’t explain why I could play as one team and get credited for playing an entirely different team. It feels like a very odd design choice to have an interaction point between finishing a match and processing the results that can replace the entire team information the match was based on.

Edit: I did notice a few times that event progress may get stuck on client side, e.g. pet battles or Invasion repeatedly showing the same stage until backing out and reentering the event. The server still knows the right stage and credits it correctly, so repeatedly picking the first pet battle actually starts the one supposed to come up. Maybe this is somehow related.

#5

Thanks for the information, I’ve made a note of it and linked it to the issue we have for the Pet battles taking awhile to update. It seems a bit nebulous at this point but if it happens again please kindly grab a screenshot as well so we can look into it further.

1 Like
#6

And it happened again, yet another 340 gems spent on sentinels for the attempt to get a top guild score down the drain.

This is the team I used for my first Guild Wars fight today on Green day:

This is the team I got credited for using on the victory screen:

grafik

This is the score I got awarded, missing roughly 400 points:

grafik

Would somebody please look into the logs of that fight and figure out how to fix this? Given that I have been hit by this twice now and considering that most players probably don’t understand Guild Wars scoring enough to notice, it’s reasonable to assume this is a very common occurrence.

I’m fairly sure I could trigger this reliably to my advantage with a bit of fiddling around, running every Guild Wars match with my favorite Rope Dart steamroller while still getting credited for using a fully color compliant team. I’m also willing to bet this is already getting exploited like crazy, because the advantages are just too juicy to pass up.

3 Likes
#7

No clue what you are doing.

#8

What were the opponents/Guild you fought? You can PM this to me if you like. Sorry this happened :frowning:

#9

What an outrageous bug. I hate it.
Now that I’m aware that this exists thanks to this thread, I do recall like a month ago having a daily task competed completely by accident, fulfilling the requirements doing something completely different to what was asked.
Didn’t pay much attention to it, I thought that I had probably misread it, but it was definitely this known issue.
I’m going to do some experimenting with daily tasks from now on until I can find a pattern that triggers this nonsense.

#10

Sorry for the late reply, busy weekend.

I don’t remember the guild, it happened on green day, fighting the first opponent. You should be able to see this in your logs. Avoiding time zone difficulties, I posted the update here right after completing the match, so if you go back roughly 30 minutes from the forum time stamp you should be able to home in on it quite accurately.

The issue is highly unlikely to be based on which guild or which opponent you fight. Something causes the game to revert to a previously played team. My gut feeling is that there are two team selection states, a global and a local one. The local one holds the selection information shown when facing the next opponent. Some sequence of actions causes the local state to get lost, either by not flushing back to the global state or by getting overwritten by the global state.

I suspect one of the actions in this sequence might be paying 50 gold to scout the opponent team, possibly a side effect introduced by fixing the free scouting exploit earlier this year. It would be interesting to hear from other players having encountered the issue which VIP level they are at.

1 Like
#11

Thanks, we’re looking into this with the team. :slight_smile:

1 Like