Guild task and reward not working

Hi all, since today i continue to receive notification of new email, but when i check there is no message at all. Even when i complete or someone complete a guild task the email is not present and i don’t receive any reward.

It was working normally yesterday

3 Likes

See my post in the 3.0 Issues - Both Android and Steam have the same issue.

Logging out and then relogging in only resets to show the blinking light again but still no guild task rewards.

1 Like

Im having the same problem since the game updated today.

Hi all. I have de same problem only today. When this would be solved? I don’t want to lose my rewards…

1 Like

One of the nicest things about filing a ticket with Support - is they will get you your rewards and then some.
Just let them know what you’re missing - not sure if anyone is working today since it’s their Saturday.

Update: @Nimhain posted she was in the office this weekend to get everyone handled :). That’s why I so love this group!!!

1 Like

I am having the same problem with guild task!!!

1 Like

The thing is, you don’t know what you’re missing.
For example, if you login in the morning, and have the blinking email, you will see your daily login email.
But there might have been guild task rewards, and you’ll never know which ones…

They should check every active account and fix them…
Hopefully they can with a script

But they generally give more to be sure. A couple of times I filled a ticket after the guild completed all the tasks (and I didn’t get all the rewards of course) and I got the full week worth of resources (590 Gems, 9 Maps and so on) even though I missed only some of them. From their responses I guess they just re-reward all the tasks done in the week if you missed any.

1 Like

This is a known issue that the team are pushing a fix out for.

It’s been detailed in the 3.0 thread found here where the issue will also be updated on. 3.0 Known Issues

1 Like