Gems not clocking on my Troop Mana

Not always but randomly, when I make a gem match that should count towards my total mana of a troop, the game disregards the match completely and does not count it. Any one else experience this?


A mana match thru gem matches is a privilage not a right. I celebrate with a shot everytime i earn a single mana. If you can capture this on video you will be our champion.

1 Like

Newbie here so maybe I explained it wrong. When I match gems, sometimes they dont count. The game disregards. Probably shouldn’t have said mana…

1 Like

Happens to all of us for months almost a year now. The devs always want a video from when it happens… They should have plenty by now, but still the issue is there.

My guess this is intentional to give the AI a better chance.

1 Like

Every time a dev has asked for a video, nobody has provided one. Heck, I’ve been the one asking a lot of the time. I think I’ve noticed stuff like this before, but it wound up being a timing issue: I would match/explode gems, and the game would update my mana total before the on-board animations finished.

If it were that easy to provide a video of the bug, you’d think someone would have done it by now.


They want a video. Really? That’s a bad joke.
I can second the issue but I’m too lazy making a video on switch, turn it off, remove my SD card,…

It happens, it’s more often then you might think (maybe 1 time every 20 games or so), it’s pretty random.

1 Like

Thanks for all the replies. At least I know it’s not just me. Wish Devs would look into this. Not cool.

1 Like

Providing proof of a bug is a natural part of bug reporting. How is it a joke?

1 Like

User wants the devs to play test to verify to use the bug is not occuring.

1 Like

It’s mostly a delay/visual bug that happen after the game is running from a while, happened to me too (and still happen).

Took a video too once it happened (ps4 always record the last 15 mins of play so you can save the video anytime), IN GAME the mana from last match was missing, “tabbed to desktop”, watched the video and there all was fine, “tabbed” again to the game and now the mana was there too.

Isnt a fix tho, tried again tab in and out another time it happened and nothing changed, also sometimes, like a fortune teller that predict the future, game add the mana even before (or at soon i start move) i start move the gem giving me the impression i didnt got any mana while instead i got it.

Best advice is to restart the game often, seen am lazy i just stopped bothering about this.

1 Like

This thread should be in the Bug Report section, not here.
I am not sure if the developers will take a look at it here.

@Kafka should tell us.

1 Like

This is proofed by number of people reporting it. Should be enough.

…ehhh… Yes.

1 Like


The reason we ask for videos is because we can’t reproduce the issue in our games here and we can’t find the issue in the code.

A video will help us pinpoint what is causing the issue.

The reason we have continuously asked for videos every single time is because no one has provided a video where the issue actually occurred.

Every time we’ve had any video about it the game was on 4x speed and it was just the player didn’t notice the Mana being added.

With more videos we can work out ok, this is actually a bug or, if every time a video is taken the mana is correctly added when the video is play backed slower than the 4x animation speed in game, then we can say ok, it’s not a bug but maybe we can improve the visual communication so players can see what’s happening better.

Right now we’ve got nada :frowning: if we can repro the issue, find it in code or get videos of it actually happening we can do something about it.

Side note, if you’re on Windows 10 on PC there’s a really handy feature you can turn on which lets you record hte last 30 seconds of gameplay, so even if it happens while you’re not recording, you can quickly switch it on and capture what happened for us.


OK. It’s not my thread and I don’t want to stress it too much.
I’m a gamer, not producing video content. And I play on Switch not on PC. I know I can take 30 sec. videos and I know how I could post them here but it’s not important enough for me. I’d rather play the game this 30 mins I would need to do this.

I think:
It’s reported (not only by the thread opener but also from me and others in the past). It’s not proven by a video so far. OK.
Play the game half an hour and it might happen one time. Play it half a day and it most probably happens several times.

You say you’ve got nada - so I have to believe this.

It’s really not that big of an issue that I’d like to prove it in any way. Game is good enough to play and live with it.

Just an idea, you could offer a bug bounty of, say, 100 gems, for the first player to provide video proof that the issue exists. I’m really curious if that would cause something to show up.


Of note: 100 gems is between $2 and $3 in real-money value, so it is probably not worth anyone’s time doctoring a video to submit for the bounty. It does, however, run the risk of normalizing bounties for bugs.

If it would help improving the game: Why not having a Bug-Bounty-Weekend every - let’s say - 3 months?

I get this happen a lot [maybe something to do with animations atx2 or x3 speed?
But I have checked, been at for example 12/15 mana, made a match of my colour, and after, been at 12/15 mana. Same happens for extra turns [sometimes it just ignores them, both from extra gems and from abilities that give you an extra turn]. Also yes, I checked no one was frozen, nothing sucked mana!
Most annoying though, is when you see a 4 match, the computer does not make it [makes only a 3 match], gives itself a free turn, THEN matches 4 … so it does things out of order. Also sometimes, it just gives itself extra turns with no justification.
These fauts have been going on since I started playing.
The no mana one is pretty common.

It really is not. I could understand if it was for example 2/15 mana, after a match its 2/15 mana, and after another match it suddenly jumps to 8/15 mana [as if not displaying the change to 5/12 mana, but it still “being there”.
Many times I have been for example on 12/15 mana, and after a match, still been on 12/15, abilities not ready.
Or if enchanted, 14/15 mana [so no mana jump].

I have no video equipment to record. But it is definitely not just “not being noticed”, or at least, not always. As I mentioned above, I have several times been 1 match away from being able to activate an ability on my first character, and made a match, and still not been able to activate ability.
So it is a thing that happens, although I am sure its more often a perception issue than actual instances, it does happen for sure.